Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

pdflatex build errors/warnings in bottom pane

Help
2010-11-19
2013-04-24
  • Michael Scholz
    Michael Scholz
    2010-11-19

    Hey!

    ubuntu 10.10, gedit 2.30, latex-plugin 0.2

    I recently switched from rubber to pdflatex and wonder how I can get errors and warnings displayed in the bottom pane. When I switch back to rubber it also does not work any more. How can I fix this, preferably for use with pdflatex?

    Thanks! Michi

     
  • Hi Michi,

    in the plugin's context, the "pdflatex" invocation is called a "job" and each "tool" consists of one or more jobs. The translation of a command's output to error messages is done by a "post processor". There is no user interface integration for specifying this post processor, yet. So you have to edit the "tools.xml" file and set the post processor of your pdflatex job to "LaTeXPostProcessor".

    Greets,
    Michael

     
  • Michael Scholz
    Michael Scholz
    2010-11-20

    Moin!
    Thanks for you reply. You say there is no interface integration for specifying this post processor? In v0.2 I have the possibility to change the post processor, see screenshot . The changes I apply there are also visible in the tools.xml.
    However, now it works after just opening the tools.xml, reordering some tool IDs and saving.
    This plugin especially with synctex support is just awesome! Thanks a lot.

    Michi