Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#2 Weapons not limited

closed-fixed
nobody
None
5
2007-11-27
2007-11-26
Burzmali
No

When equipping an weapon on a Mecha, the message 'BACKPACK_Weapon_Need2Hands': "This weapon is too heavy for you to use in just one hand" can be generated without the affecting the player's ability to equip the weapon onehanded.

From: EquipItemFrontend in backpack.pp

Discussion

  • Joseph Hewitt
    Joseph Hewitt
    2007-11-27

    • status: open --> open-fixed
     
  • Joseph Hewitt
    Joseph Hewitt
    2007-11-27

    Logged In: YES
    user_id=1753058
    Originator: NO

    That's the intended behavior. Any weapon can be used in one hand, but will suffer a serious penalty to attack rolls if it's too big. The message has been changed to hopefully make this more clear.

     
  • Joseph Hewitt
    Joseph Hewitt
    2007-11-27

    • status: open-fixed --> closed-fixed
     
  • Burzmali
    Burzmali
    2007-11-27

    • status: closed-fixed --> open-fixed
     
  • Burzmali
    Burzmali
    2007-11-27

    Logged In: YES
    user_id=1907337
    Originator: YES

    So the penalty is inflicted as long at the second hand is occupied?

     
  • Joseph Hewitt
    Joseph Hewitt
    2007-11-27

    Logged In: YES
    user_id=1753058
    Originator: NO

    Yes, that's right.

     
  • Burzmali
    Burzmali
    2007-11-27

    • status: open-fixed --> closed-fixed