Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Home

Ioan

Welcome to GeanyEasyUnicodeInput wiki!

See also: http://wiki.geany.org/plugins/start


  • I downloaded GeanyEasyUnicodeInput.zip
    unzipped,
    typed make,
    got <<Package gtk+-2.0="" was="" not="" found="" in="" the="" pkg-config="" search="" path.="">>
    More at [1]

    locate `gtk+-2.0.pc'
    finds nothing

    I'm running Ubuntu 12.04
    Your help appreciated
    Richard H

    [1]
    $ make
    gcc -Wall -Wextra \ -c GeanyEasyUnicodeInput.c -fPIC \ pkg-config --cflags geany
    Package gtk+-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `gtk+-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    Package 'gtk+-2.0', required by 'Geany', not found
    GeanyEasyUnicodeInput.c:10:25: fatal error: geanyplugin.h: No such file or directory
    compilation terminated.
    make: *** [GeanyEasyUnicodeInput.o] Error 1

     
    • Ioan
      Ioan
      2013-12-25

      Hello Richard,

      Maybe next two commands will help with building GeanyEasyUnicodeInput:

      $ apt-get install libgtkmm-2.4-dev
      $ apt-get install intltool

      First command installs all header files for gtkmm-2.4. This is used to install all
      gtk+-2.0 header files.

      Second command may be needed. I don't know if it is required, but except from
      wasting a little hard-disk space, running the command should not do any harm.

      I hope this message helps.

      Best Regards,
      Marius


      On Wed, 12/25/13, Richard Hardwick r_hardwick@users.sf.net wrote:

      Subject: [geanyeasyunicodeinput:wiki] Discussion for Home page
      To: "[geanyeasyunicodeinput:wiki] " Home@wiki.geanyeasyunicodeinput.p.re.sf.net
      Date: Wednesday, December 25, 2013, 7:42 AM

      I downloaded
      GeanyEasyUnicodeInput.zip

       unzipped,
      
       typed make,
      
       got <>
      

      More at [1]
      locate `gtk+-2.0.pc'

      finds nothing
      I'm running Ubuntu 12.04

      Your help appreciated

      Richard H
      [1]

      $ make

      gcc -Wall -Wextra \ -c GeanyEasyUnicodeInput.c -fPIC \ pkg-config --cflags geany

      Package gtk+-2.0 was not found in the pkg-config search
      path.

      Perhaps you should add the directory containing
      `gtk+-2.0.pc'

      to the PKG_CONFIG_PATH environment variable

      Package 'gtk+-2.0', required by 'Geany', not
      found

      GeanyEasyUnicodeInput.c:10:25: fatal error: geanyplugin.h:
      No such file or directory

      compilation terminated.

      make: *** [GeanyEasyUnicodeInput.o] Error 1

      Sent from sourceforge.net because you indicated interest
      in https://sourceforge.net/p/geanyeasyunicodeinput/wiki/Home/
      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/