#952 Bourne Shell color syntax highlighting

v1.24
closed-invalid
Unknown
5
2014-04-13
2013-05-09
Massimo
No

LXDE PcLinuxOS, Geany 1.23

After encountering the << keyword, syntax highlighting stops working from the next line up to end fo the document

Related

Bugs: #952

Discussion

  • Massimo
    Massimo
    2013-05-09

    problem with << keyword

     
    Attachments
    bug
  • AravindhanK
    AravindhanK
    2013-06-07

    more speacifly the bug appears
    after
    << "Any String"

     
  • Massimo
    Massimo
    2013-06-07

    Hi.
    No, I really meant from the next line, as it behaves to me.

    Regards.
    Massimo

    ----Messaggio originale----

    Da: aravindlinux@users.sf.net

    Data: 07/06/2013 6.01

    A: "[geany:bugs] "952@bugs.geany.p.re.sf.net

    Ogg: [geany:bugs] #952 Bourne Shell color syntax highlighting

    more speacifly the bug appears

    after

    << "Any String"
    

    [bugs:#952] Bourne Shell color syntax highlighting

    Status: open

    Created: Thu May 09, 2013 09:41 AM UTC by Massimo

    Last Updated: Thu May 09, 2013 09:41 AM UTC

    Owner: nobody

    LXDE PcLinuxOS, Geany 1.23

    After encountering the << keyword, syntax highlighting stops working from the next line up to end fo the document

    Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/geany/bugs/952/

    To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #952

  • AravindhanK
    AravindhanK
    2013-06-07

    yup.I understand .I meant keyword << does not make
    

    the bug reproducible, it is reproduced if it is follwed by
    double quote pairs.
    As per my knowledge it is a bug in Scintilla.

     
    Last edit: AravindhanK 2013-06-07
    • labels: --> highlighting, Filetypes, bash, Scintilla
    • status: open --> closed-fixed
    • assigned_to: Colomban Wendling
    • Group: --> v1.24
     
    • labels: highlighting, Filetypes, bash, Scintilla --> highlighting, Filetypes, bash, Scintilla, shell
    • status: closed-fixed --> pending-invalid
     
  • Hum no, wait. The above commit fixed a bug, but your example file looks buggy.

    The << shell operator introduces an HereDocument string, which is delimited by the following identifier or string, like:

    cat << EOF
    this is inside
    the HereDoc
    EOF
    # and this is outside, EOF was the delimiter
    

    I'm not sure what your snippet was supposed to mean, but for me both Bash and Dash recognizes it as an unterminated HereDocument string -- and don't understand the "proc" function.

     
    • status: pending-invalid --> closed-invalid
    • Found in: --> Unknown