This is an excellent project y'all have here. I'm loving it!
A few suggestions:
1) To be consistent with .Net naming conventions, change the namespace from Google.KML to Google.Kml (See System.Xml as an example). "KML" should also be changed to "Kml" in method and property names.
2) Again to be consistent with .Net naming conventions, remove the "ge" prefix from the names of all Google.KML objects.
3) Overload the constructors of the geCoordinates and gePoint classes to accept latitude and longitude directly, such as:
public geCoordinates(double latitude, double longitude, double? altitude)
note that altitude is nullable.
Thanks for making your work available!
Thanks for the feedback. I'll keep your suggestions in mind for future releases.
I'll echo the hearty thanks(!!!) and also these suggestions, especially removing the 'ge' prefixes. They seem to be a minor wart - a hangover from the flat namespace world. I know that doing so would break existing clients though, so it is probably too late.