Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1 How to install?

closed-invalid
nobody
None
5
2005-12-08
2005-12-03
bwiese
No

I've read the INSTALL file which just has the standard
configure/make/make install... but I've only gotten the
./configure to work. (running Ubuntu hoary)

gdmap-0.7.0 $ make
make: *** No targets specified and no makefile found.
Stop.

???

I tried the ./autogen.sh script... all seems to work
good (after installing a few tools) except for a few
warnings. Here's all the output:

gdmap-0.7.0 $ ./autogen.sh
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.59
checking for automake >= 1.9...
testing automake-1.9... found 1.9.4
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... found 2.6.3
checking for intltool >= 0.25...
testing intltoolize... found 0.33
checking for pkg-config >= 0.14.0...
testing pkg-config... found 0.15.0
Checking for required M4 macros...
Checking for forbidden M4 macros...
Processing ./configure.ac
Running glib-gettextize... Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po/Makefile.in.in

Please add the files
codeset.m4 gettext.m4 glibc21.m4 iconv.m4
isc-posix.m4 lcmessage.m4
progtest.m4
from the /usr/share/aclocal directory to your autoconf
macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which
you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

Running intltoolize...
no need for patching file 'Makefile.in.in'
Running aclocal-1.9...
/usr/share/aclocal/pkg.m4:5: warning: underquoted
definition of PKG_CHECK_MODULES
run info '(automake)Extending aclocal'
or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/libxosd.m4:9: warning: underquoted
definition of AM_PATH_LIBXOSD
/usr/share/aclocal/gtk.m4:7: warning: underquoted
definition of AM_PATH_GTK
/usr/share/aclocal/gnucash.m4:9: warning: underquoted
definition of AM_PATH_GNUCASH
/usr/share/aclocal/glib.m4:8: warning: underquoted
definition of AM_PATH_GLIB
/usr/share/aclocal/g-wrap.m4:7: warning: underquoted
definition of AC_GWRAP_CHECK_GUILE
/usr/share/aclocal/g-wrap.m4:23: warning: underquoted
definition of AM_PATH_GWRAP
/usr/share/aclocal/avifile.m4:21: warning: underquoted
definition of AM_PATH_AVIFILE
Running autoconf...
Running autoheader...
Running automake-1.9...
INSTALL INSTALL.autogen_bak differ: byte 114, line 4

I don't know where to go now... how to setup the alocal
files (if there necessary) or anything else. Any
suggestions?

I looking forward to using this great app!

Brian

Discussion

  • Markus Lausser
    Markus Lausser
    2005-12-08

    Logged In: YES
    user_id=53561

    No need to use ./autogen.sh unless you use the cvs version.

    The package is installed with
    ./configure && make && make install

    If configure runs without errors, there should be a Makefile
    and make shouldn't complain about it.
    I guess configure didn't run without errors.

     
  • Markus Lausser
    Markus Lausser
    2005-12-08

    • status: open --> closed-invalid