ERROR | Unable to load contact list!

Help
Bushveld
2009-03-05
2013-04-23
  • Bushveld
    Bushveld
    2009-03-05

    Hello

    I have downloaded the latest gcaldaemon the setup worked fine and the sync of my Calender is perfectly ok.

    Only LDAP does now work:

    ERROR | Unable to load contact list!
    java.lang.Exception: Login failed (check username/password)!
            at org.gcaldaemon.core.GmailEntry.connectLDAP(GmailEntry.java:231)
            at org.gcaldaemon.core.GmailEntry.connect(GmailEntry.java:147)
            at org.gcaldaemon.core.GmailPool.borrow(GmailPool.java:98)
            at org.gcaldaemon.core.ldap.ContactLoader.loadContacts(ContactLoader.java:274)
            at org.gcaldaemon.core.ldap.ContactLoader.run(ContactLoader.java:220)

    I have used the configurator to set this all up so I would assume that the password is ok since it works for the calender.

    Do you have any idea what I can check or do?

    Thanks
    Jock

     
  • Jasper Oz
    Jasper Oz
    2009-11-28

    Sorry bushveld, this is a "me too"…

        ERROR | Unable to load contact list!
        java.lang.Exception: Login failed (check username/password)!
                at org.gcaldaemon.core.GmailEntry.connectLDAP(GmailEntry.java:231)
                at org.gcaldaemon.core.GmailEntry.connect(GmailEntry.java:147)
                at org.gcaldaemon.core.GmailPool.borrow(GmailPool.java:98)
                at org.gcaldaemon.core.ldap.ContactLoader.loadContacts(ContactLoader.java:274)
                at org.gcaldaemon.core.ldap.ContactLoader.run(ContactLoader.java:220)

    Configured it all manually and had the file-based Cal sync working ok until I discovered the LDAP side stopped working recently (which may well be related to recent changes in the OS - Linux Mint kept up to date).

    Removed all ^M on the end of each line in the config file (no change).
    Disabled all other services (no change).
    Identified that dbus uses port

    Reconfigured using config-editor.sh and verified the Gmail account prior to saving config (no change).

    Identified dbus likes port 9080:

        $ netstat -a | grep 9080
        unix  3               STREAM     CONNECTED     9080     @/tmp/dbus-nOOojEq2Io

    so moved to ldap.port=9085 (no change).

    Noticed in config file passwords vary:

        $ grep -e enabled -e password /usr/local/sbin/GCALDaemon/conf/gcal-daemon.cfg
        progress.enabled=false
        extended.sync.enabled=true
        # Password for HTTP proxy authentication (use password encoder!)
        proxy.password=
        http.enabled=false
        file.enabled=true
        # Gmail password (use password encoder!)
        file.google.password=838$$**************
        file.offline.enabled=true
        feed.enabled=false
        ldap.enabled=true
        # Gmail password (use password encoder!)
        ldap.google.password=839$$**************
        notifier.enabled=false
        # Gmail password (use password encoder!)
        notifier.google.password=283$$**************
        sendmail.enabled=true
        # Gmail password (use password encoder!)
        sendmail.google.password=283$$**************
        mailterm.enabled=false
        # Gmail password (use password encoder!)
        mailterm.google.password=328$$gbv1WZhRGbhN2Z

    which appears to contradict the online docs (rectifying made no difference).

    File based sync, GMail notifier and sendmail aspects all working fine.

        $ uname -a
        Linux cabriolet 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 18:40:08 UTC 2009 i686 GNU/Linux

     
  • Jasper Oz
    Jasper Oz
    2009-11-28

    Addendum: the sendmail element fails to deliver (yet warns):

        WARN  | Unexpected sendmail error!
        java.lang.Exception: Login failed (check username/password)!
                at org.gcaldaemon.core.GmailEntry.connectLDAP(GmailEntry.java:231)
                at org.gcaldaemon.core.GmailEntry.connect(GmailEntry.java:147)
                at org.gcaldaemon.core.GmailPool.borrow(GmailPool.java:98)
                at org.gcaldaemon.core.sendmail.SendMail.run(SendMail.java:160)

    but if the LDAP module is disabled, then it works without uttering such warnings.

     
  • Hi Guys,
    same problem here.

    No news about this problem?

     
  • Jon Downey
    Jon Downey
    2010-02-26

    I would appreciate a reply as well. I am using Thunderbird 3, previously Outlook Express., LDAP not functioning in either.

     
  • doni49
    doni49
    2010-03-04

    Same here.

     
  • I'm having the same problem as well.  I guess I'll have to go back to using the Zindus extension for Thunderbird until this is rectified.

     
  • osmin martinez
    osmin martinez
    2010-03-21

    Same issue..verified all settings as instructed and no luck.

    ERROR | Unable to load contact list!
    java.lang.Exception: Login failed (check username/password)!
            at org.gcaldaemon.core.GmailEntry.connectLDAP(GmailEntry.java:231)
            at org.gcaldaemon.core.GmailEntry.connect(GmailEntry.java:147)
            at org.gcaldaemon.core.GmailPool.borrow(GmailPool.java:98)
            at org.gcaldaemon.core.ldap.ContactLoader.loadContacts(ContactLoader.jav
    a:274)
            at org.gcaldaemon.core.ldap.ContactLoader.run(ContactLoader.java:220)

    C:\Program Files\GCALDaemon\bin>netstat -an|findstr 9080

    C:\Program Files\GCALDaemon\bin>
    C:\Program Files\GCALDaemon\bin>java -version
    java version "1.6.0_03"
    Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
    Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)

     
  • I've got the same problem, too.

     

  • Anonymous
    2011-06-06

    Same problem…. all guts, no glory.

     
  • BaT
    BaT
    2011-06-07

    Anybody has a working LDAP, or google changed the login process??

     
  • Roel Beckers
    Roel Beckers
    2011-07-06

    Same issue here…
    Installed GCALDaemon on OS X and using Thunderbird 5.0.

    Any tips are highly appreciated…

     
  • db
    db
    2012-02-06

    "Me too"

     

  • Anonymous
    2012-05-02

    the same problem. any ideas?

     

  • Anonymous
    2012-12-07

    i have got same problem.