Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

GCALDaemon not Syncing with GCAL anymore

Mark
2008-01-10
2013-04-23
  • Mark
    Mark
    2008-01-10

    Hi.

    I recently set up my settings to subscribe to two of my own calendars on Gcal, and I got it to sync. I do not know what has happened since then, but now my calendars are not syncing.

    I use a Laptop that is not always connected to the internet, but it is connected to the internet at least 2 hours a day, so it should have adequate time to sync with Gcal.

    I tried "sync" from the start menu, and I tried "Refresh Remote Calendars" on Sunbird.

    Any ideas or suggestions of places to check for problems?

    I got it to work once, but it doesn't work now.

     
    • aberkes
      aberkes
      2008-01-28

      Use "file-based sync" in offline mode:

      http://gcaldaemon.sourceforge.net/usage-b.html#offline

      or you can synch your calendars in "Sync-on-demand" mode (using sync-now script):

      http://gcaldaemon.sourceforge.net/usage2.html#offline

       
    • RupertGee
      RupertGee
      2008-02-21

      Mark

      I was experiencing the same thing.  My GCALDaemon stopped working suddenly when it was running perfectly for months!  I thought maybe Google changed something. aberkes' suggestion doesn't help as I'm already using the offline method (on my Mac and syncing to iCal). 

      It turns out, for some unknown reasons, the file permissions for the various GCALDaemon support files were changed.  Following the original installation instructions to chmod them fixed the problem. 

      sudo chgrp -R admin /Applications/GCALDaemon
      sudo chmod -R g+w /Applications/GCALDaemon
      sudo chmod 755 /Applications/GCALDaemon/bin/*.sh