Problem solved:
After I searched for several days, I found that it is an common problem on Ubuntu, the solution is as follow:

However, if your USB key doesn't support spin down (advanced power management), you could use the following script:

while [ true ]
touch /media/YOUR_HD_NAME/.keephdactive
sleep 4m


Enjoy ~~~

2009/12/7 <>
Ok, this auto mount problem is solved after reading document about fstab
I now use "UUID=6368746f-2074-616b-6f65-207575696400 /mnt/btdown ext3 auto,rw 0 0"

But why sda1 sdb1 ex-change ~?

2009/12/7 <>
And also when I want to use fstab to auto mount the USB key: (adding "UUID=6368746f-2074-616b-6f65-207575696400 /mnt/btdown/ ext3 defaults,errors=remount-rw 0 1" into fstab)

I get (... ... non-contiguous ... ...) when I reboot whiite, and couldn't get into the system anymore.

Please help ~~~ ~~~

2009/12/7 <>

Hi, All

Have anyone met the same problem?

I am using MLDonkey to download files, and set the shared_directory & temp_directory to /mnt/usbkey/incoming & /mnt/usbkey/temp
Following is what I did:
1. insert a USB key with ext3 into my wii
2. start up whiite
3. using "mount /dev/sda1 /mnt/usbkey"
4. start "mlnet &" to download bt
However, after some while (less than 1 hour), the speed comes to 0 byte/s, and then I find no /dev/sda1 any more. Instead, there is a new /dev/sdb1, when I mount the /dev/sdb1, I find the content are exactly the same on my USB key, which mean now the USB key comes to /dev/sdb1 ~~~ When I reboot wii, it comes back to /dev/sda1

That prevents me from continous downloading files ~ anyone any idea?