Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Hello.

Help
dusee
2006-12-07
2013-04-19
  • dusee
    dusee
    2006-12-07

    Hello, I have all of the dependencies installed via the readme. When I cd into my directory in order to build gaia with the scons command I recieve the following error:

    -DGAIA_VERSION="\"0.1.2\"" -Wall -K -D_GNU_SOURCE=1 -D_REENTRANT -DDATADIR="\"./data\"" -DGAIA_VERSION="\"0.1.2\"" -Wall -K -DDATADIR="\"./data\"" -Ilib/wwfetch -I/usr/local/include -I/usr/X11R6/include -I/usr/include/SDL -I/usr/include/libpng12 -c -o programs/gaia/EarthView.o programs/gaia/EarthView.cc
    sh: -G: invalid option

    Then it just dumps out.
    I tried with the flag -k, to no avail. Any idea what I am doing wrong?
    Any help much appreciated!
    Regards.

     
    • dusee
      dusee
      2006-12-07

      Sorry. It apparently is in the earthview.h file?

      I also get this error.

      scons: *** [programs/gaia/EarthView.o] Error 2
      scons: building terminated because of errors.

       
    • That is very strange error. What system/compiler/scons version do you have?

      That string (-DGAIA_VERSION=...) should actually start with compiler name, but in your case these arguments are passed to shell instead of gcc...

      You may try this instead of just calling scons:

      CC=gcc CXX=gcc scons use_env=1