Problem with HDD > 128 Gb

  • Michel


    I apologize for my poor English (i'm French)

    I installed GAG on a notebook Maxdata 8100IS (manufactured on september 2005) with this "mapping" :

    sda1 NTFS     7 Go primary with Windows 2000
    sda2 NTFS    42 Go primary
    sda3 NTFS    42 Go primary
    sda5 Swap   500 Mo
    sda6 ext3     7 Go         /     for Linux Debian 1
    sda7 ext3    49 Go         /home for Linux Debian 1
    sda8 ext3 # 1,5 Go         /     for Linux Debian 2 (for maintenance tools)

    But GAG see :

    A Floppy
    B 07h OS/2 HPFS or Win-NT NTFS (OK)
    C 07h OS/2 HPFS or Win-NT NTFS (OK)
    D 07h OS/2 HPFS or Win-NT NTFS (OK)
    E 82h                          (OK)
    F 83h Linux ext2               (OK)
    G 83h Linux ext2               (OK)
    H FFh
    I FFh
    J FFh
    K FFh

    So it can boot Windows 2000 (on B) and the 1st Linux (on F), but not the 2nd Linux.
    I've tried with G to K and i always have the message "boot sector infected".

    I think (but perheaps it is false) the problem comes from this :
    - Originally this netbook had a 60 Gb HDD
    - I replaced it with a 160 Gb HDD
    - It seems the BIOS does not access above 128 Go, and there no newer release
      I think that because :
      . Partition saving ( worked under MS-DOS with the old HDD
      . It does'nt work on MS-DOS with the new HDD, but works under Linux
      . It works under MS-DOS on another PC which has 2 x HDD, each with much more than 128 Gb

    The 2nd Linux can be booted from GRUB2 of the 1st Linux.
    Of course, i would like to boot it from GAG, to have the 3 OS completely independent

    So, is there a way to obtain that ?
    Thank you for your answers.