#18 Install probems - gtkmm and sigc dependencies

Miriam Robinson

I am trying to install gabber (because my gaim died and
I can't get it to work again - no protocols??). I
downloaded gabber 0.8.8 and did ./configure, but it
halted because it could not find gtkmm 1.2.5 or higher
(why not put this into the package?).

I downloaded gtkmm 2.2.2 and did ./configure, but it
stalled because it could not find sigc++1.2.5 (why not
include this in the package?),

I downladed libsigc++1.2.5 and did ./configure, ./make
and ./make install - no hassles. Went back to gtkmm -
same problem. Am I installing the right thing?

I tried sigc++-1.2.5 again with ./configure
--prefix=/usr/bin in case it was installing it to the
wrong place (why not make this standard across all
packages?) - did not help. Did I do that wrong?

I tried an earlier version of gtkmm 2.0.8 - same
problem. Error messages attached. Is there a trick to
installing these extra bits that I am not getting?
Perhaps this could to in the the instructions. I am
fairly new to Linux, so dont' understand all the
complexities yet and some of the explanations are
fairly cryptic to me.


  • Logged In: NO

    I also have this problem.
    what a wonderful job if all these neccesary files are
    included in the package or more instructions in the INSTALL
    file like where to find the required packages or libraries.

  • Logged In: NO

    Gabber 1 does not work with gtk2. It's as simple as that. The Gtk
    developers broke the API going from gtk 1 to gtk 2. You need to
    find gtkmm 1 if you want to use Gabber 1.

  • Logged In: NO

    I'm having the same problem. I'm doing the install as root
    on a RH9.0
    new installation. Someone pls help as I really do want to
    replace the
    working GAIM w/ this much cooler Gabber!