#11 Installed but receiving error

open
Julian Missig
None
4
2002-03-09
2002-03-08
Anonymous
No

[root@localhost my-rpms]# rpm -iv
gnomemm-1.2.2-1.ximian.1.i386.rpm
Preparing packages for installation...
gnomemm-1.2.2-1.ximian.1
[root@localhost my-rpms]# rpm -iv
gnomemm-1.2.2-1.ximian.1.i386.rpm
Preparing packages for installation...
package gnomemm-1.2.2-1.ximian.1 is already installed
[root@localhost my-rpms]# rpm -iv
gtkmm-devel-1.2.8-1.ximian.1.i386.rpm
Preparing packages for installation...
gtkmm-devel-1.2.8-1.ximian.1
[root@localhost my-rpms]# rpm -iv
gnomemm-devel-1.2.2-1.ximian.1.i386.rpm
Preparing packages for installation...
gnomemm-devel-1.2.2-1.ximian.1
[root@localhost my-rpms]# rpm -iv
gabber-0.8.7-1_rh7.i386.rpm
Preparing packages for installation...
gabber-0.8.7-1_rh7
[root@localhost my-rpms]# find / -name *gabber -print
/usr/bin/gabber

[root@localhost my-rpms]# /usr/bin/gabber
/usr/bin/gabber: error while loading shared libraries:
/usr/lib/libgnomemm-1.2.so.9: undefined symbol:
gtkmm_marshal_INT__POINTER__FP10_GtkObjectPFe_vPvP7_GtkArg
[root@localhost my-rpms]# /usr/bin/gabber
/usr/bin/gabber: error while loading shared libraries:
/usr/lib/libgnomemm-1.2.so.9: undefined symbol:
gtkmm_marshal_INT__POINTER__FP10_GtkObjectPFe_vPvP7_GtkArg
[root@localhost my-rpms]#
[root@localhost my-rpms]#

Discussion

  • Julian Missig
    Julian Missig
    2002-03-08

    • priority: 5 --> 4
    • assigned_to: nobody --> julian
    • status: open --> pending
     
  • Julian Missig
    Julian Missig
    2002-03-08

    Logged In: YES
    user_id=9539

    What distribution are you on? Where did you get libsigc++,
    gtkmm, gnomemm? What distribution were they compiled for?
    You got the Red Hat 7 version of Gabber, so I assume you're
    on Red Hat 7, right?

     
  • Logged In: NO

    Hi Julian.

    What distribution are you on?

    GT: Redhat 7.2

    Where did you get libsigc++,gtkmm, gnomemm?

    Got them from your Web site except I think libsigc++ was
    already installed from the distributions CDs. Should I
    replace it with the version from your site?

    What distribution were they compiled for?You got the Red Hat
    7 version of Gabber, so I assume you're on Red Hat 7, right?

    GT: Yes RH 7.2

    Gary

     
  • Julian Missig
    Julian Missig
    2002-03-09

    • status: pending --> open
     
  • Julian Missig
    Julian Missig
    2002-03-09

    Logged In: YES
    user_id=9539

    Yeah, upgrade your libsigc++ to the Ximian one linked to.

    It's possible Ximian broke the libraries with their latest
    RPMs, I don't know.

     
  • Logged In: NO

    It looks like the libgnommemm-1.2.so.9 is broken from
    package gnomemm-devel-1.2.2-1.ximian.1.i386.rpm or
    gabbergnomemm-1.2.2-1.ximian.1.i386.rpm

    Should I report this to Ximian as well ?

    [root@localhost my-rpms]#
    gabber: relocation error: /usr/lib/libgnomemm-1.2.so.9:
    undefined symbol:
    gtkmm_marshal_INT__POINTER__FP10_GtkObjectPFe_vPvP7_GtkArg
    [root@localhost my-rpms]# find / -name libgnomemm* -print
    /usr/lib/libgnomemm-1.2.so.9.0.3
    /usr/lib/libgnomemm-1.2.so.9
    /usr/lib/libgnomemm.la
    /usr/lib/libgnomemm.so
    [root@localhost my-rpms]# ls
    gabber-0.8.7-1_rh7.i386.rpm
    gnomemm-1.2.2-1.ximian.1.i386.rpm
    gnomemm-devel-1.2.2-1.ximian.1.i386.rpmgnomemm-1.2.2-1.ximian.1.i386.rpm
    gtkmm-1.2.8-1.ximian.1.i386.rpm
    gtkmm-devel-1.2.8-1.ximian.1.i386.rpm
    libsigc++-1.0.3-ximian.3.i386.rpm
    netscape-i686-pc-linux-gnu-installer.tar.gz
    netscape-installer
    red-carpet-1.2.3-ximian.6.i386.rpm
    [root@localhost my-rpms]#