#457 gtkmm problem

normal
open
nobody
binaries (50)
5
2003-06-20
2003-06-20
Anonymous
No

I have tried to rpmbuild the lastest .src.rpm file
(version 0.8.8) but it keeps giving me an error . I'm
running RH 9 and installed the gtkmm files w/o problems...

jefuller@metopsdesk2 gabber]# rpm -qa | grep gtkmm
gtkmm-1.2.10-fr3
gtkmm-devel-1.2.10-fr3

checking for GTK-- - version >= 1.2.5... no
Could not run GTK-- test program, checking why...
The test program failed to compile or link. See the
file config.log for the exact error that occured. This
usually means GTK-- was incorrectly installed*** or
that you have moved GTK-- since it was installed. In
the latter case, you may want to edit the gtkmm-config
script: /usr/bin/gtkmm-config

configure: error: Cannot find gtkmm 1.2.5 or greater.

John
jfuller@wsi.com

Discussion

  • Julian Missig
    Julian Missig
    2003-06-20

    Logged In: YES
    user_id=9539

    I don't know why gtkmm's configure check would fail.. You
    installed the libsigc++ and gtkmm RPMs from freshrpms.net?
    Try getting the gabber tarball, and using ./configure
    --prefix=/usr --sysconfdir=/etc --disable-gtkmmtest and then
    'make' and see if it compiles correctly.

    You might as well just get the Gabber binary from freshrpms
    as well if you don't need any special configure options.

     
  • Logged In: NO

    Both of these worked...thanks...:D

    It was much easier jsut to download all of the files from
    the RPMS site .

    John

    I don't know why gtkmm's configure check would fail.. You
    installed the libsigc++ and gtkmm RPMs from freshrpms.net?
    Try getting the gabber tarball, and using ./configure
    --prefix=/usr --sysconfdir=/etc --disable-gtkmmtest and then
    'make' and see if it compiles correctly.

    You might as well just get the Gabber binary from freshrpms
    as well if you don't need any special configure options.