IP Tables newer Version Supported ?

GerryG
2012-11-20
2013-03-05
  • GerryG
    GerryG
    2012-11-20

    I'm changing over a server to use FWBuilder instead of raw IP Tables commands.  The current setup with the raw commands was done by a consultant that left awhile ago and did a lousy job of documenting what he did.  I'm trying to pick up the pieces. :-(

    Even though the Firewall was working before, when I converted over to doing it with FWBuilder I was getting a bunch of errors like "WARNING: The state match is obsolete. Use conntrack instead." The Firewall would compile alright but it wouldn't install.

    I kept trying to fix my commands in the FWBuilder interface and had no luck at it.

    I finally found this online,

    "Iptables >= 1.4.16 and fwbuilder doesn’t work"
    http://www.mbse.eu/2012/11/iptables-1-4-16-and-fwbuilder-doesnt-work/

    That talks about the same error I get.  And if I check he did install the same version of IP Tables.

    iptables -V
    iptables v1.4.16

    So is that post right?  There needs to be some upgrade before I can use it?

    Sorry if my facts or details are off!

    GerryG

     
  • Vadim Kurland
    Vadim Kurland
    2012-11-20

    the warning about "state match is obsolete" is only a warning, it won't cause install to fail. If it fails, there must be other errors.