Sub-Interface as management interface (linux)

Codeman
2010-09-15
2013-03-05
  • Codeman
    Codeman
    2010-09-15

    Hi,

    simple question: I have one interface (eth0) and a sub interface (eth0:0). My SSH daemon listens on the IP adress of eth0:0. I can only set up one interface with two addresses and mark this interface as "Management interface".

    When I will install the firewall thorough ssh I get the "wrong" adress of eth0… how can I tell fwbuilder to use the other address?

    Thanks, Holger

     
  • Vadim Kurland
    Vadim Kurland
    2010-09-15

    what does it mean you get "wrong" address of eth0 ? Please provide the output of command "ip addr show" before and after install

     
  • Codeman
    Codeman
    2010-09-16

    Sorry, I see that my description is a little bit too short.

    This is the config of the interface eth0:

    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
        link/ether 00:aa:ff:ff:ee:a4 brd ff:ff:ff:ff:ff:ff
        inet 183.184.85.80/30 brd 183.184.85.81 scope global eth0
        inet 108.67.208.100/30 brd 108.67.208.101 scope global eth0:0
        inet6 2123:748:c7:50:1::1/64 scope global
           valid_lft forever preferred_lft forever
        inet6 fe80::2aa:ffff:feff:eea4/64 scope link
           valid_lft forever preferred_lft forever

    What I mean is:
    - I add an interface eth0 to my firewall object
    - I check the "Management interface" box
    - I add 3 IP addresses: 183.184.85.81 (IPv4, eth0), 108.67.208.101 (IPv4, eth0:0) and 2123:748:c7:50:1::1 (IPv6)

    The sshd only listens on the second one: 108.67.208.101 (eth0:0) becaus this is my managament IP adress.

    When I start the installation of the firewall (via ssh) I get the address of eth0 (183.184.85.81) filled into the text field "Address that will be used to communicate with the firewall:"

    How do I tell fwbuilder to use the second address (of eth0:0) for installing via ssh?

    Thanks, Holger

     
  • Vadim Kurland
    Vadim Kurland
    2010-09-16

    you can enter the right address in the "Alternative name or address … " input field in the "Installer" tab of the firewall object settings dialog.

     
  • Codeman
    Codeman
    2010-09-16

    Ahhh! Great! That solves my problems.

    Thanks a lot!!!

    Holger