iptables switch format incorrect

Des G
2012-04-06
2013-03-05
  • Des G
    Des G
    2012-04-06

    I am using Centos 6.2 with iptables v1.4.7

    Using a time schedule generates an error on install as follows:

    Rule 9 (global)
    iptables v1.4.7: unknown option `-days'
    Try `iptables -h' or 'iptables -help' for more information.

    From the man page, the option required is -weekdays, not -days

    Is there any way I can work around this?

    Cheers, Des.

     
  • Des G
    Des G
    2012-04-06

    Changing the version of iptables in fwbuilder from 'any' to '1.4.4 or later' resolved the issue.

    Cheers, Des.

     
  • Hi Des,

    I have the same problem.

    iptables v1.4.7: unknown option `-days'

    Could you please explain in details what you did to fix the issue? I have CentOS 6.2 and I've just added xtables-addons.

    Don't xtables-addons come with the time module?

    Thanks in advance.