Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Another drive not getting mounted

Anonymous
2009-11-04
2013-04-24

  • Anonymous
    2009-11-04

    Mounts perfectly in Linux or Windows with ext2fsd.. also, disk1s2 mounts (disk1s1 doesnt mount as expected as it is a swap partition)

        fdisk /dev/disk1
        Disk: /dev/disk1 geometry: 121601/255/63
        Signature: 0xAA55
                Starting       Ending
        id  cyl  hd sec -  cyl  hd sec

        1: 83    0   1   1 -   62 254  63  Linux files*
        2: 83   63   0   1 -  187 254  63  Linux files*
        3: 83  188   0   1 - 1023 254  63  Linux files*
        4: 00    0   0   0 -    0   0   0  unused   

        diskutil list
        /dev/disk0
        #:                       TYPE NAME                    SIZE       IDENTIFIER
        0:      GUID_partition_scheme                        *250.1 GB   disk0
        1:                        EFI                         209.7 MB   disk0s1
        2:                  Apple_HFS Macintosh HD            215.7 GB   disk0s2
        3:       Microsoft Basic Data BOOTCAMP                34.0 GB    disk0s3
        /dev/disk1
        #:                       TYPE NAME                    SIZE       IDENTIFIER
        0:     FDisk_partition_scheme                        *1.0 TB     disk1
        1:                      Linux                         518.2 MB   disk1s1
        2:                      Linux                         1.0 GB     disk1s2
        3:                      Linux                         998.7 GB   disk1s3

        sudo fuse-ext2 /dev/disk1s3 ~/Desktop/1tb/ -o debug -v
        fuse-ext2: enter
        fuse-ext2: leave
        Mounting /dev/disk1s3 Read-Only.
        Use 'force' or 'rw+' options to enable Read-Write mode
        fuse-ext2: opts.device: /dev/disk1s3
        fuse-ext2: opts.mnt_point: /Users/gaarder/Desktop/1tb/
        fuse-ext2: opts.volname: 
        fuse-ext2: opts.options: debug
        fuse-ext2: parsed_options: debug,allow_other,local,ro,fsname=/dev/disk1s3,fstypename=ext2,volname=disk1s3
        fuse-ext2: mounting read-only
        unique: 0, opcode: INIT (26), nodeid: 0, insize: 56
        INIT: 7.8
        flags=0x00000000
        max_readahead=0x00100000
        fuse-ext2: enter /dev/disk1s3
        mount_fusefs: failed to mount /Users/gaarder/Desktop/1tb@/dev/fuse2: Socket is not connected
        fuse-ext2: FileSystem ReadOnly
        fuse-ext2: leave
        INIT: 7.8
        flags=0x00000000
        max_readahead=0x00100000
        max_write=0x00400000
        unique: 0, error: 0 (Unknown error: 0), outsize: 40
        fuse: writing device: Socket is not connected
        fuse-ext2: enter
        fuse-ext2: leave

     
  • Alper Akcan
    Alper Akcan
    2009-11-04

    hi,

    btw, after installing the software, please do a reboot - not needed but just to be clear -. and it should automount he harddrives, and usb drives once they connected.

    thanks, alper.

     

  • Anonymous
    2009-11-05

    svn revison 194 works perfectly for readonly mode, but rw+ gives the same error. Thanks for the quick update and keep up the good work!

     
  • Alper Akcan
    Alper Akcan
    2009-11-12

    hi,

    reading map data from a big drive causes the problem. i am trying to fix the issue with write support,too. hopefully it will be available with next release - in 1-2 weeks -.

    alper.

     
  • Alper Akcan
    Alper Akcan
    2009-12-11

    hi,

    sorry for late reply, i will release a new version nextweek friday. which will also have option for rw mount in prefpane. thank you for your interest.

    alper.

     
  • Taxman
    Taxman
    2009-12-18

    Yeah, I'm in the same situation. Thanks for your work. This is a very important driver. Eagerly awaiting the release.