Transcoding the audio portion of MKV only


  • Anonymous

    Fuppes version: 0.675
    Platform: Ubuntu 10.4
    ffmpeg svn compiled from scratch on 9/23/10

    I'm trying to force the transcoding of the audio-only portion of my mkv videos when they come with dca audio, as my TV and DVR (Moxi) cannot deal with DTS, only AC3. Given that, I set up my config file as this (transcoding portion only):

    <file ext="mkv">
               <transcode enabled="true">

    I verified that ffmpeg -format does indeed display h264, dca, and ac3 as available for both, encoding and decoding (except dca that is decoding only).

    Fuppes does not seem to be doing anything at all here, so when I'm connected to my main Receiver, that can process DTS, all goes well, but if I'm connected in a secondary TV with no receiver and no DTS decoding capabilities, I get no audio output, so this is clearly still being sent as DTS (displayed on my main receiver).

    Any suggestion here?