403 Access Denied with build 686

Help
2011-08-31
2013-04-25
  • Adam Kessel
    Adam Kessel
    2011-08-31

    I just upgrade from svn 680 to 686. Although the server runs, if I attempt to access it from anything other than localhost, I get a 403 error. Using same configuration as before.

    Here's what I get telnetting to the port from any computer but the one fuppes is running on:

    HEAD / HTTP/1.1

    HTTP/1.0 403 Forbidden
    Content-Type:
    Content-Length: 0
    Accept-Ranges: bytes
    Pragma: no-cache
    Cache-control: no-cache
    Connection: close
    DATE: Wed, 31 Aug 2011 03:00:21 GMT
    EXT:
    Server: Linux/2.6.39-2-686-pae, UPnP/1.0, FUPPES/0.686

    Any suggestions?

     
  • Adam Kessel
    Adam Kessel
    2011-08-31

    Seems to be something wrong with allowed_ips. I was using the same expression as before:

    <ip>192.168.98.*</ip>
    

    Which corresponds to my LAN. If I remove all ip limitations, I have access.

     
  • Adam Kessel
    Adam Kessel
    2011-08-31

    One other problem with 686 build - options page gives 404 page not found error.

     
  • Adam Kessel
    Adam Kessel
    2011-08-31

    Another apparent bug: I am only seeing files in the deepest levels.

    E.g., if I have a folder /home/movies/A/B/C.mp4 and /home/movies/A/D.mp4, and my top level directory is configured as /home/movies/A, I don't see D.mp4. Only C.mp4. In other words, for the top directory, it is only showing directories, not files. It only shows files in the deepest-buried directory.

     
  • Adam Kessel
    Adam Kessel
    2011-08-31

    This last problem seems to relate to a trailing slash. If I include the trailing slash, I get the files in the directory, but none of the subdirectories. If I don't include the trailing slash, I only get the subdirectories, not the top level.