installation on SUSE 10.2

Help
pito41
2007-09-12
2013-04-25
  • pito41
    pito41
    2007-09-12

    Hi,
    i'm a linux newBe.
    having issues with the installation,see ./configure log:

    This file contains any messages produced by compilers while
    running configure, to aid debugging if configure makes a mistake.

    It was created by configure, which was
    generated by GNU Autoconf 2.61.  Invocation command line was

      $ ./configure

    ## --------- ##
    ## Platform. ##
    ## --------- ##

    hostname = DLNA-LINUX
    uname -m = i686
    uname -r = 2.6.18.2-34-default
    uname -s = Linux
    uname -v = #1 SMP Mon Nov 27 11:46:27 UTC 2006

    /usr/bin/uname -p = unknown
    /bin/uname -X     = unknown

    /bin/arch              = i686
    /usr/bin/arch -k       = unknown
    /usr/convex/getsysinfo = unknown
    /usr/bin/hostinfo      = unknown
    /bin/machine           = unknown
    /usr/bin/oslevel       = unknown
    /bin/universe          = unknown

    PATH: /sbin
    PATH: /usr/sbin
    PATH: /usr/local/sbin
    PATH: /opt/kde3/sbin
    PATH: /opt/gnome/sbin
    PATH: /root/bin
    PATH: /usr/local/bin
    PATH: /usr/bin
    PATH: /usr/X11R6/bin
    PATH: /bin
    PATH: /usr/games
    PATH: /opt/gnome/bin
    PATH: /opt/kde3/bin
    PATH: /usr/lib/jvm/jre/bin
    PATH: /usr/lib/mit/bin
    PATH: /usr/lib/mit/sbin

    ## ----------- ##
    ## Core tests. ##
    ## ----------- ##

    configure:1819: checking for a BSD-compatible install
    configure:1875: result: /usr/bin/install -c
    configure:1886: checking whether build environment is sane
    configure:1929: result: yes
    configure:1994: checking for gawk
    configure:2010: found /usr/bin/gawk
    configure:2021: result: gawk
    configure:2032: checking whether make sets $(MAKE)
    configure:2053: result: yes
    configure:2290: checking for g++
    configure:2306: found /usr/bin/g++
    configure:2317: result: g++
    configure:2348: checking for C++ compiler version
    configure:2355: g++ --version >&5
    g++ (GCC) 4.1.2 20061115 (prerelease) (SUSE Linux)
    Copyright (C) 2006 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    configure:2358: $? = 0
    configure:2365: g++ -v >&5
    Using built-in specs.
    Target: i586-suse-linux
    Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --libexecdir=/usr/lib --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.1.2 --enable-ssp --disable-libssp --disable-libgcj --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --program-suffix=-4.1 --enable-version-specific-runtime-libs --without-system-libunwind --with-cpu=generic --host=i586-suse-linux
    Thread model: posix
    gcc version 4.1.2 20061115 (prerelease) (SUSE Linux)
    configure:2368: $? = 0
    configure:2375: g++ -V >&5
    g++: '-V' option must have argument
    configure:2378: $? = 1
    configure:2401: checking for C++ compiler default output file name
    configure:2428: g++    conftest.cpp  >&5
    configure:2431: $? = 0
    configure:2469: result: a.out
    configure:2486: checking whether the C++ compiler works
    configure:2496: ./a.out
    configure:2499: $? = 0
    configure:2516: result: yes
    configure:2523: checking whether we are cross compiling
    configure:2525: result: no
    configure:2528: checking for suffix of executables
    configure:2535: g++ -o conftest    conftest.cpp  >&5
    configure:2538: $? = 0
    configure:2562: result:
    configure:2568: checking for suffix of object files
    configure:2594: g++ -c   conftest.cpp >&5
    configure:2597: $? = 0
    configure:2620: result: o
    configure:2624: checking whether we are using the GNU C++ compiler
    configure:2653: g++ -c   conftest.cpp >&5
    configure:2659: $? = 0
    configure:2676: result: yes
    configure:2681: checking whether g++ accepts -g
    configure:2711: g++ -c -g  conftest.cpp >&5
    configure:2717: $? = 0
    configure:2816: result: yes
    configure:2850: checking for style of include used by make
    configure:2878: result: GNU
    configure:2906: checking dependency style of g++
    configure:2996: result: gcc3
    configure:3061: checking for gcc
    configure:3077: found /usr/bin/gcc
    configure:3088: result: gcc
    configure:3326: checking for C compiler version
    configure:3333: gcc --version >&5
    gcc (GCC) 4.1.2 20061115 (prerelease) (SUSE Linux)
    Copyright (C) 2006 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    configure:3336: $? = 0
    configure:3343: gcc -v >&5
    Using built-in specs.
    Target: i586-suse-linux
    Configured with: ../configure --enable-threads=posix --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib --libexecdir=/usr/lib --enable-languages=c,c++,objc,fortran,obj-c++,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.1.2 --enable-ssp --disable-libssp --disable-libgcj --with-slibdir=/lib --with-system-zlib --enable-shared --enable-__cxa_atexit --enable-libstdcxx-allocator=new --program-suffix=-4.1 --enable-version-specific-runtime-libs --without-system-libunwind --with-cpu=generic --host=i586-suse-linux
    Thread model: posix
    gcc version 4.1.2 20061115 (prerelease) (SUSE Linux)
    configure:3346: $? = 0
    configure:3353: gcc -V >&5
    gcc: '-V' option must have argument
    configure:3356: $? = 1
    configure:3359: checking whether we are using the GNU C compiler
    configure:3388: gcc -c   conftest.c >&5
    configure:3394: $? = 0
    configure:3411: result: yes
    configure:3416: checking whether gcc accepts -g
    configure:3446: gcc -c -g  conftest.c >&5
    configure:3452: $? = 0
    configure:3551: result: yes
    configure:3568: checking for gcc option to accept ISO C89
    configure:3642: gcc  -c -g -O2  conftest.c >&5
    configure:3648: $? = 0
    configure:3671: result: none needed
    configure:3691: checking dependency style of gcc
    configure:3781: result: gcc3
    configure:3835: checking for pkg-config
    configure:3853: found /usr/bin/pkg-config
    configure:3866: result: /usr/bin/pkg-config
    configure:3884: checking for libpcre >= 5.0
    configure:3906: result: no
    configure:3923: error: Library requirements (libpcre >= 5.0) not met; consider
    adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a
    nonstandard prefix so pkg-config can find them.

    it seems the version of the libpcre is old then the one needed >5 ?!

    please help with the actions to perform.

    Tksss !

     
    • Ulrich Völkel
      Ulrich Völkel
      2007-09-12

      I don't think that SuSE 10.2 ships an old libpcre. I would rather guess that you need to install the appropriate -devel package. Can you please check if there is any pcre-devel, libpcre-dev or something similar available.
      You need to install the devel packages for all dependencies (libxml2, sqlite3, etc..)

      - Uli

       
      • pito41
        pito41
        2007-09-12

        Hi,

        thanks a lot ! i installed all the -devel packages and re run the ./configure script.

        see the output :
        "
        SUMMARY

        transcoding disabled

        no encoding library was found
        If you want transcoding install LAME and/or TwoLAME
        and run ./configure again

          taglib support disabled
          libnotify support disabled

        Thanks for using fuppes"

        Do you know how to enable the transcoding ,installing LAME ?

        Best Regards,
        Pito

         
      • roan
        roan
        2008-01-13

        hi,
        I've run into the same error on open suse 10.3. after installing pcre-devel with all dependencies I still run into continuous errors the next missing pakage was libxml and now I'm stuck with sqlite3 the error I get is:
        >checking for SQLITE3... configure: error: Package requirements (sqlite3 >= 3.2) were not met:
        although I installed "libapr-util1-dbd-sqlite3 - DBD driver for SQLite 3"

        got any Ideas?

         
        • FunkySquid
          FunkySquid
          2008-01-13

          Try installing sqlite3-devel

           
    • Ulrich Völkel
      Ulrich Völkel
      2007-09-12

      I don't know if there exists any third party lame packages for SuSE but I guess it does.
      If not you can compile it yourself.
      Get the source from http://lame.sf.net and build it like this
      ./configure --prefix=/usr
      make
      make install

      - Uli

       
    • pito41
      pito41
      2007-09-17

      Hi,

      Great i installed the Lame packages for SUSE and then rebuilding Fuppes,
      after starting the Server application and displaying the Info with the command
      "i",there's still a print indicating that the transcoding's not supported ?
      any idea ?

      Pito.

       
    • Ulrich Völkel
      Ulrich Völkel
      2007-09-17

      And ./configure said that it found lame?
      Do you get any warning at fuppes startup that libmp3lame could not be loaded?

      - Uli

       
    • pito41
      pito41
      2007-09-18

      Hi,
      Snip of the "./configure" of the Fuppes package:
      ...
      SUMMARY

        audio transcoding enabled
          encoder:
            lame   : yes
            twolame: no
          decoder:
            vorbis : yes
            mpc    : no
            flac   : no

        taglib support disabled
        libnotify support disabled

      Thanks for using fuppes
      please report bugs
      ...
      There's no error message when starting Fuppes application,see the print system info:

      general information:
        version     : 0.7.1
        hostname    : DLNA-LINUX
        OS          : Linux 2.6.18.2-34-default
        build at    : Sep 12 200713:53:30
        build with  : 4.1.2 20061115 (prerelease) (SUSE Linux)
        address     : 192.168.1.141
        sqlite      : 3.3.8
        log-level   : 1 (normal)
        webinterface: http://192.168.1.141:2060/

      compiled without transcoding support.

      Is going to the vesion 0.7.2a will solve this issue ?

      Regards,
      Pito

       
    • Ulrich Völkel
      Ulrich Völkel
      2007-09-18

      Can you please use the latest release (SVN-524) and check if it behaves the same way.

      - Uli

       
    • roan
      roan
      2008-01-14

      can't find the pkg in any repo or any howto on the net, you got a tip how to install on opensuse?
      thnxx

       
      • FunkySquid
        FunkySquid
        2008-01-14

        I'm an Ubuntu user, and I had to install the dev package on my machine, so that's where my suggestion comes from. I'm not sure the exact steps to install on opensuse, but google tells me the packages are available.

        See http://packages.opensuse-community.org/index.jsp?searchTerm=sqlite&distro=openSUSE_102 and more specifically the package "sqlite-devel".