#203 MP4 plugin fails to compile

open
nobody
None
5
2011-09-17
2011-09-17
Robert Mason
No

On my Debian 'sid' system, the mp4 plugin fails to compile, as it is using a deprecated (and apparently now absent) libmp4v2 metadata API. Debian reports my version of libmp4v2-2 as 1.9.1+svn479~dfsg0-2. I patched src/plugins/metadata_libmp4v2.cpp to use the new interface (attached).

I don't use MP4 files, so I can't attest to whether it actually works or not (if you need me to I can transcode something and test it out), but at least it gets past compilation now.

--
rbmj

Discussion

  • Robert Mason
    Robert Mason
    2011-09-17

    Patch

     
    Attachments
  • Robert Mason
    Robert Mason
    2011-09-17

    Sorry I didn't realize there was a separate patch section. Reposting to patches, and sorry for incorrectly posting.