#480 Typing doesn't work

closed
nobody
None
8
2012-09-03
2010-07-24
Nicholas Shanks
No

When editing a fleet name, or choosing "Save Game" from the in-game "Menu" button, only the delete key is recognised, and none of the alphabetic characters can be typed.

Discussion

  • Geoff Topping
    Geoff Topping
    2010-07-24

    • status: open --> open-works-for-me
     
  • Geoff Topping
    Geoff Topping
    2010-07-24

    I can't reproduce this. Typing when renaming fleets from the right-click pop and when saving games works fine for me.

     
  • What OS are you on?
    There is no category or group option available for selecting the affected OS. I am running Mac OS 10.6

    I didn't yet try renaming a planet, nor any of the in-game shortcut keys for moving around the UI.

     
  • Geoff Topping
    Geoff Topping
    2010-07-24

    I'm using the Win32 version.

     
  • Isaac Supeene
    Isaac Supeene
    2010-07-25

    I can't reproduce this on OS X 10.6

     
  • I have the problem as well. Unable to enter text in the text fields for renaming fleets, naming designs, and save game.

    Windows Vista SP2 (32 bit).

     
  • Geoff Topping
    Geoff Topping
    2010-07-25

    nickshanks and kwikung: What language are your operating systems set to? Any non-Latin characters in your keyboard mapping? Do hotkey keyboard keypresses such as f and g have any effect (should cycle through fleets)?

     
  • Geoff Topping
    Geoff Topping
    2010-07-25

    • priority: 5 --> 8
    • status: open-works-for-me --> open
     
  • US english. Swedish keyboard.

    However, after a couple of restarts of the game, it works, and I am unable to trigger the problem :-/

     
  • okay, I'm a bit tired, which makes my brain stupid.

    This seems to trigger the problem:

    start game in windowed mode
    load saved game
    go straight to design
    click in the visible design's name box, type something (sdifjlsf), that works
    select an empty hull from the left side list (for example small hull)
    try typing again, now the problem is triggered

     
  • Geoff Topping
    Geoff Topping
    2010-07-26

    When you "select an empty hull from the left side list" do you single or double click?

    Do you re-select the text entry box in the "Design Details" panel next "Design Name" after selecting the empty hull?

    (I still can't reproduce this.)

     
  • I just launched, loaded my saved game (started yesterday by choosing "Single Player"), and was able to type in the rename fleet box. I tried switching keyboard layouts in the OS between British, Russian and Hebrew, but that had no effect. I did notice that the keyboard layout used by the game always seemed to be US however. For example Shift-3 always produced a # sign (not what the British layout would produce). No russian or hebrew characters were typed, only Latin script ones.

    I also tested on my gf's Win Vista 32-bit using a quickstart game and typing worked there as expected. But reading the recent comments it seems like there are certain trigger steps that need to be followed. I will investigate later today and see if I can get it to break under certain conditions report what those were. I haven't the time now.

     
  • single click, then click in the text box again to type.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here


    Anonymous
    2010-10-01

    I have this. Ubuntu 10.04 LTS
    Free orion 0.3.15

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here


    Anonymous
    2010-10-01

    EDIT to previous. this only occurs after task-switching out and back in.

     
  • This happened to me once and it has to do with running in windowed mode and alt-tabbing. Using Kubuntu 10.04 LTS. Restarting the game fixed it though. FYI I'm also running synergy and vmware workstation in the background so that could have been an issue as well. Like I said only once so far.

     
  • I also had this problem recently, when switching desktop. I had to press the Control key to make typing work again. And I agree on the fact *some* of the keyboard is not used as it should (I’m using bépo, which is a french version of dvorak, and letters work, as well as [+_=/], but none of the others do).

    I suppose Alt-tabbing could also do the trick.

     
  • Geoff Topping
    Geoff Topping
    2012-09-03

    At least on Windows, FreeOrion handling of international keyboard layouts should be significantly improved in the latest SVN. The OS-set keyboard layout is recognized, and as long as the stringtable that is being used supports the relevant characters, typing should also work in the chat and galaxy setup dialogs with non-Latin characters.

    The comments on this bug report have been a mix of unrelated issues, so I'm going to close this bug for now. If the issues with no or almost no typing after alt-tabbing are still happening, please re-post.

     
  • Geoff Topping
    Geoff Topping
    2012-09-03

    • status: open --> closed