#329 Loading saves causes crash (was: Disabling fps limit )

Latest Subversion
closed-accepted
nobody
Client (126)
5
2008-04-03
2008-02-03
thetallman13
No

Loaded game on xp, after changing the setting (turning off fps limit) in a previous session. Game load started, game crashed, and this was the output:

1202035620 DEBUG : Disabled FPS limit
HumanClientApp::HandleMessage(HOST_SP_GAME)
1202035678 ERROR : ClientNetworking::NetworkingThread() : Networking thread will be terminated due to disconnect exception "Reached the end of file."

PS I'm rather new to this whole alpha testing thing. Tell me if I n00bed this up too much :).

Discussion

  • thetallman13
    thetallman13
    2008-02-03

    Logged In: YES
    user_id=1184452
    Originator: YES

    Update: It does the same thing when re-enabling the fps limit, except now it says DEBUG : Limited fps to 60. I don't seem to have the problem when I start a new game. Maybe changing the setting then saving botched the save game?

     
  • Geoff Topping
    Geoff Topping
    2008-02-03

    Logged In: YES
    user_id=913462
    Originator: NO

    Can you be more specific about the exact steps you're taking to produce this? From initially starting the program, exactly what do you click in what order, on what screens? Did you try loading that same game without having changed anything and not get a crash? What do you mean by "a previous session"?

     
  • thetallman13
    thetallman13
    2008-02-05

    Logged In: YES
    user_id=1184452
    Originator: YES

    Alright, it went something like this:
    I started the program after installing, and the first thing I did was to turn the fps limiter off (I wanted to see what that did mainly). I started a new game, played some turns, and saved. I quit the game. When I tried to load the saved game later, I got the above error. When I re-enabled the fps limiter and tried to load again, I got the error in my first update. When I start a new game I get no error.

    Hope that was a little more clear :).

     
  • Geoff Topping
    Geoff Topping
    2008-02-05

    Logged In: YES
    user_id=913462
    Originator: NO

    Have you successfully loaded any games? You seem to be saying that you can't load a game regardless of whether the FPS limit is on. If you first tried loading after changing the FPS limiter settings doesn't mean the latter caused the crash.

    To test your theory (corrupted save game), perhaps you could make a new game, save it, and attempt to load it without touching the FPS setting?

    Also, I really do need specific exact steps to produce the crash. There are several ways and places where you could load a game, so saying "When I tried
    to load the saved game later" is not precise. Please tell me exactly what you click on, in what order, from as soon as the program starts.

     
  • thetallman13
    thetallman13
    2008-02-05

    Logged In: YES
    user_id=1184452
    Originator: YES

    Okay, did what you said, tried creating another save game. This is what I have come up with.

    These are the two sets of circumstances under which the program has crashed for me so far.

    #1:
    1. I started the program
    2. I clicked on "Single Player"
    3. The game crashed with said fps error.

    #2:
    1. I started the program
    2. I clicked on "Load Game"
    3. I selected saved game "tallman.sav" and clicked "Load"
    4. The load screen appeared for a moment, then the program crashed with said fps error.

    Note, #2 is what was happening in my original bug report.

    So, in response to your first question, no, I have not been able to load a single save game so far.

     
  • Geoff Topping
    Geoff Topping
    2008-02-05

    • labels: 617637 --> Client
     
  • Geoff Topping
    Geoff Topping
    2008-02-05

    Logged In: YES
    user_id=913462
    Originator: NO

    Does the FPS limit have to be disabled in either case to produce either crash? Does a new game start up normally without crashing if the FPS limit is enabled? Have you altered the show fps toggle?

    When you refer to "said fps error", do you mean the crashing, or the console output? (There's no FPS-related console error message. The DEBUG output is normal behaviour, and should be seen even if you successfully start or load a game)

    After answering the above, please delete the contents of

    /Documents and Settings/Username/Application Data/Freeorion/

    and try running the game again.

     
  • thetallman13
    thetallman13
    2008-02-05

    Logged In: YES
    user_id=1184452
    Originator: YES

    No, the fps limit does not have to be disabled to cause the problem, but I did not have the problem until I disabled the fps limiter for the first time. Creating a new game (fps limiter on or off) does not cause the crash (except for the one time I clicked single player and it crashed the program, which I have not been able to reproduce). It is only when I try to load a game that the game crashes. Said fps error is the output I get in the dosbox thingy that runs in the background while the game is running.

    What do you mean by "altered the show fps toggle"? I have turned it on and off a few times, other than that I have done nothing to it (I haven't even changed the fps number to limit).

    I cleared the files in the directory you mentioned, and repeated steps 1-4 in #2 of my previous comment. It crashed in the same manner as before. Clearing the directory doesn't appear to have changed anything. Perhaps I should try a reinstall?

     
  • Zach Laine
    Zach Laine
    2008-02-09

    Logged In: YES
    user_id=729903
    Originator: NO

    It would really help if we had some more system info. You mentioned you are running this on XP. I hope it is the 32-bit version? Any other system info that you can think of would help.

     
  • thetallman13
    thetallman13
    2008-02-10

    Logged In: YES
    user_id=1184452
    Originator: YES

    Okay, here goes:

    Windows XP sp2 version 2002 32 bit.
    Athlon 3600 socket 939 64 bit.
    Nvidia Nx8500gt vid card.
    Sound blaster Audigy sound card (don't know why but there it is anyways).

    Hope that helps in some way. I have tried different combos of reinstalling, making sure all registry entries are clear, and deleting left over files. I still have this problem no matter what I do. I even tried a system restore (this is a brand new install of xp, I have room to play around), and that had no effect as well.

    All drivers (mobo, video, sound, direct x), are at their most current versions for this OS.

     
  • Zach Laine
    Zach Laine
    2008-02-10

    • summary: Disabling fps limit causes crash --> Loading saves causes crash (was: Disabling fps limit )
     
  • Logged In: NO

    I have a similar error.

    2008-02-28 09:16:48,014 ERROR AI : ClientNetworking::NetworkingThread() : Networking thread will be terminated due to disconnect exception "The I/O operation has been aborted because of either a thread exit or an application request."
    2008-02-28 09:16:48,045 DEBUG AI : Shutting down AI_588 logger...

     
  • Geoff Topping
    Geoff Topping
    2008-02-28

    Logged In: YES
    user_id=913462
    Originator: NO

    most recent nobody:

    Your posted log messages appear to be from the AI log file, and don't contain anything indicating a problem. What makes you think you've found a bug, and what does it have to do with this bug in particular?

    Also, you appear to be using an old version of FreeOrion. Please update to the v0.3.8 release, or build from updated SVN.

     
  • Zach Laine
    Zach Laine
    2008-04-03

    Logged In: YES
    user_id=729903
    Originator: NO

    This sounds an awful lot like a firewall issue. Make sure your firewall settings allow your FreeOrion client to contact the FreeOrion server (it is launched by the client on your machine). If you can't supply a save file that will produce this crash, there's not much here for me to go on. I'm marking this pending, so if I haven't gotten more info on this in two weeks, it will auto-delete.

     
  • Zach Laine
    Zach Laine
    2008-04-03

    • status: open --> pending
     
  • Logged In: NO

    The newest RC does not appear to have this problem. I don't think it was Zone Alarm, I went through and made sure the server had full reign. Either way, it appears to have been fixed, or it fixed itself. Thanks for the help!

     
  • Zach Laine
    Zach Laine
    2008-04-03

    • status: pending --> closed-accepted