#192 Splash Screen Pixilation

v0.3
closed-invalid
nobody
Client (126)
1
2005-12-31
2005-12-23
Geoff Topping
No

The main splash screen is quite pixilated / aliased.

I'm running at 1024x768, which is the same size as the
splash image file(s) in the /default/data/art
directory. Those files look quite nice viewed outside
FO, but in the game, they are shown with big blocks
visible at the horizon of the planet.

See:
http://home.cogeco.ca/~toppingwebspace4/FO/FOSplashPixiliation.png

Discussion

  • Zach Laine
    Zach Laine
    2005-12-23

    Logged In: YES
    user_id=729903

    The original image was 1600x1200, scaled down to the size
    that is distributed with FO, 1280x960. The pixelation is a
    natural side effect of scaling.

     
  • Zach Laine
    Zach Laine
    2005-12-23

    • status: open --> closed-invalid
     
  • Geoff Topping
    Geoff Topping
    2005-12-23

    Logged In: YES
    user_id=913462

    My complaint was about in-game pixilation that does not
    appear in the splash[01][012].png files. It only appears
    once the files are loaded into the game.

    Comparison:
    http://home.cogeco.ca/~toppingwebspace4/FO/FOSplashPixiliation2.png

    If I misunderstood you, and it is supposed to be due to the
    in-game scaling, then we really need a better scaling
    algorithm. This is going from larger to smaller... there
    should not be four pixel wide blocky artifacts all over the
    image.

     
  • Logged In: YES
    user_id=26932

    Reopening this bug with low priority.

     
    • priority: 3 --> 1
    • status: closed-invalid --> open-postponed
     
  • Zach Laine
    Zach Laine
    2005-12-23

    Logged In: YES
    user_id=729903

    We have no control over the quality min- and magnification
    algorithms provided by OpenGL. We're already using the
    highest-quality one available, so there's no fix for this.
    If you show an image at any size other than its native size,
    it will look imperfect. Moreover, the image linked in the
    first post looks fine to me; is it the before or the after
    image? I also looked at the splash under all three built-in
    resolutions and do not see a problem. Please post an image
    that reflects the problem as it appears for you, or I'll
    close this bug.

     
  • Geoff Topping
    Geoff Topping
    2005-12-23

    Logged In: YES
    user_id=913462

    See my previous comment, which linked to:

    http://home.cogeco.ca/~toppingwebspace4/FO/FOSplashPixiliation2.png

    which shows the in-game image (with arrow pointing to
    blockyness) and the out-of-game image (without blockyness)
    side by side.

     
  • Zach Laine
    Zach Laine
    2005-12-31

    • status: open-postponed --> closed-invalid
     
  • Zach Laine
    Zach Laine
    2005-12-31

    Logged In: YES
    user_id=729903

    After looking at the before and after images, I can
    definitely say now that this is not a bug; this is just the
    amount of aliasing I would expect. In future, perhaps we
    should use a different image size. Right now, we have no
    default app size. If we did, we could make the image that size.