On Thu, 9 Jun 2011 14:01:48 -0300, William Grzybowski wrote:
On Thu, Jun 9, 2011 at 1:56 PM, Matt Olander <firstname.lastname@example.org> wrote:On Thu, Jun 9, 2011 at 9:26 AM, Marion DESNAULT <email@example.com> wrote:Hi, ZVols are mentioned several times in the interface but not always under the same name: ZVol, ZFS Zvol, ZFS Volume. For sake of consistency under what name should they all appear?Hi Marion, Good catch, thanks! Hrm, of course, to me, ZVol makes sense but maybe ZFS Volume is better for new users? Thoughts?We already call Volume a zfs pool, that might be confusing.. Perhaps ZFS Device is not such a bad idea?
The documentation from Oracle (http://download.oracle.com/docs/cd/E19963-01/html/821-1448/) calls zpool "ZFS Storage Pool" and zvol "ZFS Volume".
I think it is best to call ZVol by its actual name "ZFS Volume", it might be a bit confusing with "Volume" (zpool) but "ZFS Device" take us away from what it really is and called. And using directly ZVol, while being clear for people used to ZFS, might help new users to better understand what it is.
-- Marion DESNAULT