On Wed, Oct 2, 2013 at 11:27 AM, Ulf Panten <ulf.panten@ghs16.de> wrote:
> I have an encrypted ZFS volume 'vol0' that I installed a couple plugins on
> (dlna and mt-daapd). It created jails for these plugins and things worked
> great...until I rebooted.
>
> After rebooting, the plugins would no longer start (even manually after
> unlocking the ZFS volume), and before or after starting the jail manually. I
> tried removing them to reinstall, but that failed too. I tried removing
> everything from disk manually, but I cannot get the plugins or the jails to
> disappear from the web UI. Currently when I try to delete a plugin, I get
> the following error:

I've found a workaround:

After unlocking the Volume, go to

Jails -> View Jails -> Configuration and save the old (and correct) settings. The jails reappear and the plugins are working again. Of course, you can delete them, too.

I tested this with 9.1.1

Thanks everyone, I was able to delete the plugins after (re-)saving my jails configuration and updating to 9.1.1!

Cheers,
Tobias
--
Tobias McNulty, Managing Member
Caktus Consulting Group, LLC
http://www.caktusgroup.com