Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Cannot write in any nodes or options

Sandy
2011-11-08
2013-04-11
  • Sandy
    Sandy
    2011-11-08

    Hello.

    I used freemind on my last computer and I think it is an excellent tool. Trying to use it on my new computer has been problematic, however, as I cannot write anything in any nodes or options in the preferences. It otherwise loads without errors. Any advice would be greatly appreciated.

    Computer: Toshiba L735 - 11W
    OS: Puppy Linux (Slacko 5.3)
    Java version: 1.7.0
    Freemind version: 0.9.0

    All the best,

    Sandy

     
  • LogicDaemon
    LogicDaemon
    2011-11-08

    Not sure Freemind works flawlessly with JRE1.7.0, but have you tried other Java apps? Like JEdit for example.
    To determine, is this caused by freemind or system/java.

     
  • Sandy
    Sandy
    2011-11-17

    Thank you for the reply.

    I installed JEdit and found that it had the same problem i.e. not being able to write in the editor window. Also, all the menu items were unreadable as they had square characters. Looks as though it is a java issue. Any recommendations?

    Best,

    Sandy

     
  • Sandy
    Sandy
    2011-11-17

    It seems others have had similar issues. The interference of ibus with Java apps.

    https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/481656

    Of course, this doesn't help me much as I don't have any ibus daemons in puppy linux.

     
  • I propose you check whether you have OpenJDK as your Java runtine, and, if so, install Oracle Java instead of OpenJDK.

    To find out whether you are using "OpenJDK", type "java -version" into your Linux shell, and check whether you see "OpenJDK" in the output.

    See also http://freemind.sourceforge.net/wiki/index.php/OpenJDK

    -Dan

     
  • Sandy
    Sandy
    2011-11-21

    Thank you Dan,

    Checking the java version gave the following:

    # java -version
    java version "1.7.0"
    Java(TM) SE Runtime Environment (build 1.7.0-b147)
    Java HotSpot(TM) Server VM (build 21.0-b17, mixed mode)

    No sign of OpenJDK. Any other suggestions?

    Best,
    Sandy

     
  • Sandy
    Sandy
    2011-11-21

    Thank you to everyone who helped.
    I have now sorted the issue by downgrading to the previous java version.
    # java -version
    java version "1.6.0_24"

    Best,
    Sandy