Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Can't show 0.9.0 Beta 5 mm w/ browser applet

2007-07-22
2013-04-11
  • John Rouillard
    John Rouillard
    2007-07-22

    Hi all:

    I use freemind for a lot of things including project planning, and
    group brainstorming. It would be great to be able to use the browser
    applet on the mindmap attached to a topic to display it in my
    companies TWiki.

    However it seems the applet doesn't want to load the file and instead
    loads the mindmap file in another window/tab. I am left staring at a
    grey box where the mindmap should be.

    The applet tag in the html source reads (with the hostname changed):

    <applet code="freemind.main.FreeMindApplet.class" alt="Freemind java applet" codebase="https://me.example.com/twiki/pub/Main/FreeMind" archive="https://me.example.com/twiki/pub/Main/FreeMind/freemindbrowser.jar" width="100%" height="100%">
      <param name="type" value="application/x-java-applet;version=1.4">
      <param name="scriptable" value="false">

      <param name="modes" value="freemind.modes.browsemode.BrowseMode">
      <param name="browsemode_initial_map" value="https://me.example.com/twiki/pub/Main/FreeMind/freemind.txt">
     
    <param name="initial_mode" value="Browse">
    <param name="selection_method" value="selection_method_direct">
    </applet>

    The url to the mindmap of:

      https://me.example.com/twiki/pub/Main/FreeMind/freemind.txt

    works and I can view the source in my browser using that URL. In fact
    loading/reloading the page with the embedded applet tag loads the map
    URL:

        https://me.example.com/twiki/pub/Main/FreeMind/freemind.txt

    in another tab/window. This occurs under Firefox and IE 7.

    The mindmap is freemind.mm file from the 0.9.0 beta 5 release of
    freemind renamed to freemind.txt . I had to rename it to .txt so the
    entire contents of the file was returned. If I left the name as
    freemind.mm it was truncated at the first &lt;html&gt; tag.

    The only error I see in the java console when I reload the page is:

       Warning: the font you have set as standard - null - is not available.
       [Freemind-Developer-Internal-Warning (do not write a bug report,
       please)]:
       Tried to get view without being able to get map module.
       View is null.

    which isn't exactly a smoking gun. No warning about a version mismatch
    or other error. I wouldn't expect the new 0.9.0 features to be
    viewable, but the basic mindmap layout should be shown right?

    Specs:

      Web Browser: Firefox 1.5.0.12 (and IE 7)
      Browser Applet: 0.7.1 from sourceforge.net
      Java: Java Plug-in 1.6.0, Using JRE version 1.6.0 Java HotSpot(TM)
            Client VM.
      OS: Windows XP/SP2

    Is this a problem caused by the use of 0.90 with the 0.7.1 browser?
    Maybe a java 1.6 incompatibility?

    Any other ideas?

    Thanks for your help.

    -- rouilj

     
    • John Rouillard
      John Rouillard
      2007-07-22

      Ok, looks like I solved the truncation problem for files ending in
      .mm.

      The issue was that the mindmap itself uses the </html> tag. If I
      replaced the <html> </html> pairings with <ehtml> </ehtml> the file
      downloaded properly. It must be caused by the mime type of the file
      being set to text/html (as I think all unknown files are). So I
      changed the apache config adding:

        AddType application/mindmap .mm

      to /etc/httpd/conf/httpd.conf and I was able to download the mm file
      without truncation even when the </html> was in the file. This may be
      an issue only for 0.9.X as I think html text wasn't allowed in earlier
      versions (http://freemind.sourceforge.net/wiki/index.php/Development).

      The weirdness with the mindmap opening in an new window/page is a FAQ
      and is caused by a missing trailing .mm on the URL.
      (http://freemind.sourceforge.net/wiki/index.php/Asked_Questions#To_present_your_mind_map_on_the_web
      section:  My document isn't opened by the applet).

      I am still unable to display the mindmap, but the Java console is
      giving a more useful error, sort of:

      Warning: the font you have set as standard - null - is not available.
      freemind.main.XMLParseException: XML Parse Exception during parsing of a map element at line 10: Expected: /
      java.lang.Exception
          at freemind.modes.browsemode.BrowseMapModel.load(BrowseMapModel.java:115)
          at freemind.modes.browsemode.BrowseController.load(BrowseController.java:205)
          at freemind.modes.browsemode.BrowseController.loadURL(BrowseController.java:181)
          at freemind.modes.browsemode.BrowseMode.activate(BrowseMode.java:74)
          at freemind.controller.Controller.changeToMode(Controller.java:325)
          at freemind.main.FreeMindApplet.init(FreeMindApplet.java:262)
          at sun.applet.AppletPanel.run(Unknown Source)
          at java.lang.Thread.run(Unknown Source)
      [Freemind-Developer-Internal-Warning (do not write a bug report, please)]: Tried to get view without being able to get map module.
      View is null.

      The first 19 lines of the file are:

      ======= start
      <map version="0.9.0 Beta 5">
      <!-- To view this file, download free mind mapping software FreeMind from http://freemind.sourceforge.net -->
      <node COLOR="#993300" CREATED="1124560950701" MODIFIED="1124560950701">
      <richcontent><html>
        <head>
         
        </head>
        <body width="">
          <p align="center">
            FreeMind<br /><small>- free mind mapping software -</small>&#160;
          </p>
        </body>
      </html>
      </richcontent>
      <font BOLD="true" NAME="Dialog" SIZE="18"/>
      <node CREATED="1124560950701" LINK="http://freemind.sourceforge.net" MODIFIED="1124560950701" POSITION="left" TEXT="Home page of FreeMind">
      <font NAME="SansSerif" SIZE="12"/>
      </node>
      <node COLOR="#006699" CREATED="1124560950701" FOLDED="true" ID="_Freemind_Link_1091417446" MODIFIED="1125175911388" POSITION="left" TEXT="Table of key mappings">
      ===== end

      line 10 is the line that reads:

         FreeMind<br /><small>- free mind mapping software -</small>&#160;

      sadly I see no missing / on that line, and xmllint doesn't report any
      problems with the mindmap file.

      So any ideas on what is happening or further debugging I can do?

      -- rouilj