v1.0.0 will not open v0.9.0 mindmaps

Help
2013-11-28
2014-03-30
  • Background
    I have been using Freemind for several years now, both at home and at work. I don't remember which version I started with but have for sure used both 0.8.2 and 0.9.0. I tell my colleagues how useful it is and this is how I ended up in some trouble this week. One colleague sent me a mindmap for review and it was created in the latest version. I could not open it with version 0.9.0.

    Easy, just up-grade to the lates version, you say. Well, at home I run a Debian based system and 0.9.0 is the latest version in Debian's stable repo. I want to be able to bounce mindmaps between home and work so I don't want to up-grade at work unless I can do so at home.

    I downloaded the freemind-bin-max-1.0.0.zip and uncompressed it. Made freemind.sh executable.

    Symptoms
    I know the new version has fired up OK at least once but I don't remember if it was the first time. When it did it told me it was about to open a mindmap created in an older version.... I clicked "yes" and all went reasonably well. I write "reasonably" because the node texts were not rendered correctly. The text was truncated but all of it was there if I opened the editor.

    Apart from this I have had no luck. When I click "yes" at that old file warning nothing happens apart form closing that dialogue box. I could sit and look at the splash screen until the end of time it seems. There is no CPU load so I assume Freemind has hit permafrost.

    0.9.0 still works OK. No issues there.

    I have tried un-installing 0.9.0 in case there was a conflict but that changed nothing.

    Here are some CLI-output:

    martin@cb64:~/Program/Freemind$ DEBUG=1 ./freemind.sh
    DEBUG: Using $PATH to find java virtual machine.
    DEBUG: Using '/usr/bin/java' as java virtual machine...
    java version "1.6.0_27"
    OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1~deb7u1)
    OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
    DEBUG: Freemind parameters are ''.
    DEBUG: Linux cb64 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux
    DEBUG: LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch:security-4.0-amd64:security-4.0-noarch:security-4.1-amd64:security-4.1-noarch
    Distributor ID: Debian
    Description: Debian GNU/Linux 7.2 (wheezy)
    Release: 7.2
    Codename: wheezy
    DEBUG: The following DEB packages are installed:
    ii freemind 0.9.0+dfsg-2 all Java Program for creating and > viewing Mindmaps
    ii freemind-doc 0.9.0+dfsg-2 all Documentation for FreeMind
    ii freemind-plugins-svg 0.9.0+dfsg-2 all Java Plugin for FreeMind to export Mindmaps to SVG and PDF
    DEBUG: Freemind Directory is '.'.
    DEBUG: Calling: '/usr/bin/java -Dfreemind.base.dir=. -cp ::./lib/freemind.jar:./lib/jibx/jibx-run.jar:./lib/jibx/xpp3.jar:./lib/bindings.jar:./lib/commons-lang-2.0.jar:./lib/forms-1.0.5.jar:./lib/jortho.jar:./lib/xalan.jar:./lib/serializer.jar:./lib/xml-apis.jar:./lib/xercesImpl.jar:. freemind.main.FreeMindStarter '.
    Checking Java Version...

    There are also some log-files. Here are some lines:

    2013-nov-28 21:18:00 freemind.main.FreeMind <init>
    INFO: freemind_version = 1.0.0; freemind_xml_version = 1.0.1
    Build: 855

    java_version = 1.6.0_27; os_name = Linux; os_version = 3.2.0-4-amd64
    2013-nov-28 21:18:01 freemind.main.FreeMind checkForAnotherInstance
    INFO: An error occurred while connecting to the FreeMind server instance. This probably means that > FreeMind crashed and/or exited abnormally the last time it was run. If you don't know what this means, don't worry. Exception: java.net.ConnectException: Connection refused
    2013-nov-28 21:18:01 freemind.main.EditServer <init>
    INFO: FreeMind server started on port 46345
    2013-nov-28 21:18:01 freemind.main.EditServer <init>
    INFO: Authorization key is 1553274522

    Yours stumped for now,

    /Martin

     
  • No one?

    /Martin

     
  • Hi,

    to make a diagnosis, I would need a complete log file with the open-action included. Currently, all looks good.

    TIA, Chris

     
  • Like the attached file I hope.

    /Martin

     
    Attachments
  • Hi,

    nothing special in this file. Can you please send me the stack trace, when freemind hangs. Do jps and then jstack of the pid of freemind (or freemindstarter).

    TIA, Chris

     
  • Trying to run jps or jstack only results in a "no such command" reaction from my computer. I have tracked down a man page for jps on the web and to me it looks like any cli command.

    I even tried "java jps" and only got error messages.

    What am I missing?

    Other Java applications such as GPSAR and jAlbum seems to work OK.

    /Martin

     
    Last edit: Martin Schöön 2013-12-05
  • Hi,

    the tools belong to the jdk. Can you give it a try?

    TIA, Chris

     
  • martin@cb64:~/Program/Freemind$ jps 9883
    RMI Registry not available at 9883:1099
    Exception creating connection to: 9883; nested exception is:
    java.net.SocketException: Invalid argument or cannot assign requested address

    martin@cb64:~/Program/Freemind$ jstack 9883
    9883: Unable to open socket file: target process not responding or HotSpot VM not loaded
    The -F option can be used when the target process is not responding
    martin@cb64:~/Program/Freemind$ jstack -F 9883
    Attaching to process ID 9883, please wait...
    sun.jvm.hotspot.debugger.NoSuchSymbolException: Could not find symbol "gHotSpotVMTypes" in any of the known library names (libjvm.so, libjvm_g.so, gamma_g)
    at sun.jvm.hotspot.HotSpotTypeDataBase.lookupInProcess(HotSpotTypeDataBase.java:389)
    at sun.jvm.hotspot.HotSpotTypeDataBase.readVMTypes(HotSpotTypeDataBase.java:104)
    at sun.jvm.hotspot.HotSpotTypeDataBase.<init>(HotSpotTypeDataBase.java:85)
    at sun.jvm.hotspot.bugspot.BugSpotAgent.setupVM(BugSpotAgent.java:568)
    at sun.jvm.hotspot.bugspot.BugSpotAgent.go(BugSpotAgent.java:494)
    at sun.jvm.hotspot.bugspot.BugSpotAgent.attach(BugSpotAgent.java:332)
    at sun.jvm.hotspot.tools.Tool.start(Tool.java:163)
    at sun.jvm.hotspot.tools.JStack.main(JStack.java:86)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:616)
    at sun.tools.jstack.JStack.runJStackTool(JStack.java:136)
    at sun.tools.jstack.JStack.main(JStack.java:102)
    Debugger attached successfully.
    jstack requires a java VM process/core!

    I hope this helps. My own programming schooling is somewhat dated: Fortran 77 in circa 1980, a little Pascal a year or two later and some Rocky Mountain Basic later on. I am trying to catch up now by learning Python for fun.

    /Martin

     
    • Hi,

      first jps to see what processes there are, and then jstack <pid>. Please. try again. Chris

       
      • I try to post yesterday's catch again. I don't know what's up with the old one being stuck in transit.

        /Martin

         
        Attachments
  • Post awaiting moderation.
  • Hi,

    there is a dialog waiting for you. Maybe its outside of the visible screen (and you had a multi monitor setup earlier). Try moving the file "auto.properties" temporarily away (located in the .freemind directory) and have a try.

    HTH, Chris

     
  • Sorry, wrong diagnosis, but please, try the proposed remedia nevertheless. In fact, the dialog, you closed with OK is still waiting for you. I don't know why, because it is a standard dialog. Anyway, please move the auto.properties away and try again, please.

    TIA, Chris

     
    • OK, so here is what happens when I try that.

      1) Move auto.properties to other folder
      2) Invoke freemind
      3) Freemind 1.0.0 fires up right away with empty mindmap
      4) Open 'old' mindmap #1 -- works OK
      5) Open 'old' mindmap #2 -- also works OK
      6) Close freemind without saving anything
      7) Invoke freemind again
      8) Click yes in dialogue box about opening mindmap from older version of freemind.
      9) Wait forever...

      Next I tried a variation on this. I edited out all references to last opened mindmap in auto.properties and left the abused file i place. Now freemind fires up in the same manner as if there was no auto.properties -- with the only difference that the Most Recent Files list is populated.

      0.9.0 is not bothered by an auto.properties created by 1.0.0.

      /Martin

       
  • I have now tried version 1.0.0 out at work (Windows 7, 64 bit) and have no problems opening old mind maps. At home (Debian stable, 64 bit) the problem persists.

    /Martin

     
  • I have excactly the same problem. With the first start Freenet 1.0 started but hang when trying to open last opened file (created with version 0.9x). I deleted auto.properties and Freemind did start. I tried to open one of my old Freemind maps and Freemind hangs. So, currently I am not able to use my old maps, which is pretty bad, especially because Fremind 0.9 does not run under Ubuntu 13.10.

    Later: I just discovered that "Import" works. Well ...

     
    Last edit: Gerhard Lehnhoff 2014-02-25
  • Hi,

    this is java bug. Can you try to exchange the java version? Which one do you use exactly?

    HTH, Chris

     
  • Another question: do you use multiple screens? Perhaps, the dialog is outside of your screen. Please post your freemind.properties.

    TIA, Chris