Installation aborts with Java JRE 7 installed

  • Gearwheel

    Hi there!
    On my Windows 7 64bit I have Jave 7 64bit installed. But when I try to install freemind than an error shows up:
    "Java 1.4 or greater not detected. - You have to download and install Java from …."
    What´s wrong?
    Best regards from Austria!

  • Thulani

    I also just got this same problem and this is what I did to by pass that problem after I couldnt get a solution from the forums. It's not a permanent solution I am still checking for a more permanent solution.

    I went to the freemind.jar file on the lib folder (on my pc it's on C:\Program Files\FreeMind\lib) and i right cliked on freemind.jar file then "open with" then "choose program" then i browsed to the location of the latest java.exe file (on my pc it's C:\Program Files\Java\jre7\bin) and then double click java.exe

    That should open freemind with the latest java you chose. This however does not permanentlyfix the problem, to make things easier for myself I created a short cut on the desktop to the freemind.jar file and renamed the shortcut to "Start freemind". so now I always use my new shortcut whenever I am openning freemind.

    As I said, this is not a permanent solution but it will at least allow you to use freemind until you get a permanent one.