Hi,

I'm getting these errors when I run autogen.sh:

configure.ac:4: warning: The macro `AC_FOREACH' is obsolete.
configure.ac:4: You should run autoupdate.
../../lib/autoconf/general.m4:196: AC_FOREACH is expanded from...
aclocal.m4:666: _AM_SET_OPTIONS is expanded from...
aclocal.m4:393: AM_INIT_AUTOMAKE is expanded from...
configure.ac:4: the top level
configure.ac:4: warning: The macro `AC_FOREACH' is obsolete.
configure.ac:4: You should run autoupdate.
../../lib/autoconf/general.m4:196: AC_FOREACH is expanded from...
aclocal.m4:666: _AM_SET_OPTIONS is expanded from...
aclocal.m4:393: AM_INIT_AUTOMAKE is expanded from...
configure.ac:4: the top level
configure.ac:16: error: possibly undefined macro: AC_LIBTOOL_DLOPEN
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.ac:17: error: possibly undefined macro: AC_PROG_LIBTOOL
configure.ac:53: error: possibly undefined macro: AC_CHECK_LIBM
autoreconf2.50: /usr/bin/autoconf failed with exit status: 1

I have autoconf 2.61 & 2.13. I tried to make the wrapper autoreconf to use 2.13 besides 2.61 yet it did not work.
Could you guys tell how to fix this? Or maybe make a tarbal that works with the latest versions of autoconf, automake, etc.
Thanks.

Ramiro.l