4pane will not create cinfig file

Help
vradice
2013-07-27
2013-07-27
  • vradice
    vradice
    2013-07-27

    I installed 4pane looking for a different browser. When I start it, I am told that there was no configuration found. Rightly so as I just installed it. However I cannot create one. I get the following message

    Can't find 4Pane's resource files. There must be something wrong with your installation. :(
    Do you want to try to locate them manually?

    I am running Fedora Fc17_64 and installed using yum. I also installed the debugging info package. Did I miss something? How do I get this working?

     
  • David Hart
    David Hart
    2013-07-27

    Hi,

    Thank you for reporting this.

    When I start it, I am told that there was no configuration found. Rightly so as I just installed it.
    Not rightly, in fact; a default config file should be created automatically, and it should know the correct location of the resources.

    Can't find 4Pane's resource files...
    And that's what happens either when there are no config file or resource files, or when they aren't in any of the usual places.

    The rpms work for me, of course. I just checked again in my FC17_64 virtualbox guest, using
    yum --nogpgcheck localinstall 4Pane*.rpm
    and they still installed and ran correctly.
    Is that similar to how you installed? If not, what exactly did you do?

    The resource dir should be /usr/share/4Pane/rc. Could you check that that dir exists, and contains 6 files? The config file should be ~/.4Pane and should contain the line:
    ResourceDir=/usr/share/4Pane/rc/

    I'm struggling to guess what could have gone wrong. I've tested using gnome and kde. Are you using a different, unusual DE? Is this a standard FC17, or are you running a live-cd? Could your selinux setting be interfering?

    Regards,

    David