#7265 Project mercurial repository was not shown on Allura

assigned
Chris Tsai
https://sourceforge.net/p/videlibri/code/ci/tip/tree/
videlibri
2014-07-05
2014-04-04
No

The repository of my VideLibri project could not be examined on the sourceforge site anymore, for a few days.

Now I pushed new commits and it works again, so it might be too late for this ticket, but I wrote most of it already. And it had happened before, so it will happen again..

The tip-urls I used to use ( https://sourceforge.net/p/videlibri/code/ci/tip/tree/ ) and (https://sourceforge.net/p/videlibri/code/ci/tip/log/ ) returned a 404 error.

The url in the nav bar ( https://sourceforge.net/p/videlibri/code/ci/default/tree/ ) only shows "Repo status: analyzing..." (for days/weeks!) and not the side bar with branches/tags

It seems to break everytime the last commit is only setting a tag (like https://sourceforge.net/p/videlibri/code/ci/cadcc330d071bd8f66344256122d56b4554a5e12/) in the default branch, instead commiting files to the actual main branch "trunks"

Discussion

  • Chris Tsai
    Chris Tsai
    2014-07-05

    Greetings,

    The code repository update scan is triggered by a "changegroup" server-side hook, this doesn't seem to cover the case up just updating a tag. I've created a ticket with our engineering team to investigate what hooks we use: [allura:tickets:#7536]

    I suspect you could workaround this in the meantime by editing your own hooks appropriately. Perhaps by adding an identical "tag" hook to the "changegroup" one that's already there.

    Regards,
    Chris Tsai, SourceForge.net Support

     
  • Chris Tsai
    Chris Tsai
    2014-07-05

    • labels: --> engr, nf-7536
    • status: unread --> assigned
    • assigned_to: Chris Tsai