Graphics corruption - Intel graphics driver

Help
2011-10-01
2013-05-23
  • Hi,

    I checked the modules section and also adapted the grub settings to use i915.modeset but this did not improve anything. Since other OpenGL games seem to run fine (e.g. ioquake3), I don't have a clue why foobillardplus shows this issue. Running the game from command line I get the following output when starting up the game:

    ...
    extension_cubemap_ARB=1
    extension_multitexture_ARB=1
    extension_combine_ARB: 1
    extension_dot3_ARB: 1
    extension_vp_ARB: 1
    extension_ts_NV=0
    extension_rc_NV=0
    extension_vp_NV=1
    options_multisample: 1
    Anisotropic Filter 1.
    

    Maybe this can give a hint.
    Regards,
    Felix

     
  • Hi,

    I've searched and searched, but can't find a mistake inside the source-code. Before I open a bug for this chipset. All the linuxer with foobillard++ problems on GM45 Chipsets (Arch-Linux) uses the mesa-lib 7.11. The mesa team says, that this is a development release…….

    Is it possible to test the program with a mesa-lib prior 7.11 (e.g. Mesa 7.10.3)?

    Greetings

    Holger

     
  • Using kernel option i915.powersave=0 did also not work.

     
  • Hello Felix,

    to test the program for this Intel-Chipset I have to use a system with an Intel GM45. Now, I've only systems with GM55 and GM945 and Chipsets with an 3150 Media-Accelerator from Intel. No system with an GM45.

    I'm searching for it…….. Please wait

     
  • Hi Holger,

    if I may help you somehow, just let me know.

    Regards,
    Felix

     
  • Hello Felix,

    I'm very unhappy. But I can't find/get a system with an Intel GM45. I want to solve the GM45 issues, but I need a system with this chipset to do the work. Foobillard++ is Open Source and I earn no money or something similar with it and so I don't want to buy a new system only to solve problems for this chipset.

    Please be patient. If I can get a system with an GM45 I will do the work.

    Regards

    Holger

     
  • Also nvidia 9600GS has graphics corruption. The balls are not well rendered.

     
  •  
  • What for an Operating system?

    Hit ESC/Reflections/Rendering and there default or spheremap. Solve this the problem?

     
  • Holger, I was having the same problem, what you said solved it.

     
  • The image in post 5 is likely caused by using the "free" graphics driver for whatever card is in use. I had that for a couple of NVidia cards when using the "nouveau" driver (with Mageia 2). When I switched to the "nvidia" driver the table was rendered correctly. May be worth trying if you see an image like that and have the option of a commercial driver available for use for your card

     
  • I had dodgy ball rendering similar to that pictured in post 11. I am running the nvidia proprietry driver. Thankfully, changing Reflections/Rendering as described solved my problem.
    I say thankfully, but I've spent far too many hours playing the original foobillard than I'd care to admit when I really should've been doing far more productive things!!
    It's a fab game.. my thanx to the developer!!

     
  • ..also.. that music proper freaked my out when I first fired up the game!!
    I was like "where the hell's that freaky whispering coming from??"
    Thought my computer was haunted!!