#9 Support for v4l (video4linux) version 1

open
nobody
None
5
2008-03-22
2008-03-22
Victor
No

Hi,
I was trying to use FMJ to capture video from my webcam in Linux (Ubuntu 7.10), but without success because my webcam's driver implements only v4l (and not v4l2).

My webcam is Genius GF112, it uses spcaxxx driver (http://mxhaard.free.fr). This driver is very popular, it supports many cheap webcams; also there are other webcam drivers based on v4l version 1.

It would be great if FMJ supports both versions - v4l and v4l2, especially for unexperienced end-users. With FMJ supporting v4l and v4l2, Java applications could work with most popular webcams - almost like FlashPlayer works well with many webcam on different paltforms.

The original Sun's JMF supports v4l version 1 (my webcam works with Sun's JMF). Is it possible to take this part of JMF and include it into FMJ?

Thanks.

Discussion