Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1069 Toolbar incorrect rendering when composition enabled

v1.3.5
closed-fixed
nobody
5
2013-02-13
2012-10-21
Anonymous
No

Hi,

I am using Fluxbox 1.3.2 with true transparency enabled using xcompmgr rendering. Every time I connect to fluxbox, the toolbar is not well displayed. See http://i.imgur.com/u8Pdr.png for a screen caption. To counter this drawback, I have to move the toolbar on another location and then moving it back to its initial location. See http://i.imgur.com/8Q9FP.png for an example. You will notice that empty gap on the right of the icons in the notification area. I correct it by reconfiguring Fb.

Discussion


  • Anonymous
    2012-10-21

    Before redrawing the toolbar

     
    Attachments
  • Mathias Gumz
    Mathias Gumz
    2012-10-22

    how do you launch xcompmgr?

     

  • Anonymous
    2012-10-22

    Here is my .fluxbox/startup file :

    xrandr --output DVI-0 --mode 1920x1200
    xrandr --output LVDS --off
    gtk-theme-switch2 MyInverted
    conky -c ~/.conkyrc3 &
    xfce4-power-manager &
    nm-applet &
    xfce4-power-manager &
    nitrogen --restore &
    xcompmgr -C &
    # Dockapps
    wmnd &
    wmhdplop &
    cputnik &

    xscreensaver -nosplash &
    # And last but not least we start fluxbox.
    # Because it is the last app you have to run it with ''exec'' before it.

    exec /usr/bin/fluxbox

     
  • Mathias Gumz
    Mathias Gumz
    2012-11-12

    you are launching a lot of apps in parallel. all of which are fighting over with each other over attention of the xserver. regarding to your xcompmgr+fluxbox problem:

    launch xcompmgr after fluxbox is running.

    fluxbox &
    fbpid=$!

    sleep 2
    xcompmgr -C &

    wait $fbpid

    this will bring up fluxbox (and the toolbar) first. xcompmgr should then pick that up correctly.

     

  • Anonymous
    2013-02-10

    Thak you Akir, the problem is solved. I had to apply your solution and remove the exec before /usr/bin/fluxbox before executing it. Here is my new .fluxbox/startup

    export "PATH=$PATH:/home/ben/jdk1.6/bin"
    xrandr --output DVI-0 --mode 1920x1200
    xrandr --output LVDS --off
    gtk-theme-switch2 MyInverted
    conky -c ~/.conkyrc3 &
    xfce4-power-manager &
    nm-applet &
    xfce4-power-manager &
    nitrogen --restore &
    #xcompmgr -C &
    # Dockapps in slit
    wmnd &
    wmhdplop &
    /home/ben/Applications/cputnik/src/cputnik &
    knotes &
    xfce4-volumed &

    xscreensaver -nosplash &
    # And last but not least we start fluxbox.
    # Because it is the last app you have to run it with ''exec'' before it.

    /usr/bin/fluxbox &
    fbpid=$!
    sleep 2
    xcompmgr -C &
    wait $fbpid

     

  • Anonymous
    2013-02-10

    • status: open --> open-fixed
     

  • Anonymous
    2013-02-10

    • status: open-fixed --> closed-fixed