When I compile cvs version of flightgear in a gentoo and gcc-4.1 I get the following errors:

if g++ -DHAVE_CONFIG_H -I. -I. -I../../src/Include -I../.. -I../../src  -I/usr/X11R6/include -I/usr/local/include  -g -O2 -D_REENTRANT -MT groundnetwork.o -MD -MP -MF ".deps/groundnetwork.Tpo" -c -o groundnetwork.o groundnetwork.cxx; \
        then mv -f ".deps/groundnetwork.Tpo" ".deps/groundnetwork.Po"; else rm -f ".deps/groundnetwork.Tpo"; exit 1; fi
../../src/AIModel/AIBase.hxx:122: error: 'osg' has not been declared
../../src/AIModel/AIBase.hxx:122: error: expected ';' before '<' token
../../src/AIModel/AIBase.hxx:177: error: 'osg' has not been declared
../../src/AIModel/AIBase.hxx:177: error: expected ';' before '*' token
make[2]: *** [groundnetwork.o] Error 1
make[2]: Leaving directory `/home/edi/games/simuladores/fgfs/cvs/osgflightgear/tmp/src/Airports'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/edi/games/simuladores/fgfs/cvs/osgflightgear/tmp/src'
make: *** [all-recursive] Error 1

I have fixed the compilation with this patch that includes osg headers into src/AIModel/AIBase.hxx:

----------------------------------------------------------------------------
diff -urN source/src/AIModel/AIBase.hxx tmp/src/AIModel/AIBase.hxx
--- source/src/AIModel/AIBase.hxx       2006-11-26 13:02:06.000000000 +0100
+++ tmp/src/AIModel/AIBase.hxx  2006-12-28 23:11:36.000000000 +0100
@@ -33,6 +33,11 @@

 #include <Main/fg_props.hxx>

+// By Edi: Include osg layer here
+#include <osg/ref_ptr>
+#include <osg/Node>
+// End osg layer
+
 SG_USING_STD(string);
 SG_USING_STD(list);
----------------------------------------------------------------------------

There may be another cleaner way of fixing it.

If it is an error please, fix it in cvs. If not I would be interested in knowing my mistake or the circunstances that produces this error in my system.

Thanks in advance.
--
Woodyst.