Hi All,
I'm trying to put my own data into FG, with the native fdm and the generic input protocol at the same time. My problem is, that fdm works fine, but the data is send via UDP over the generic protocol has some kind of lag or rather delay. When I pause sending the data, the data in the property tree (createy by my own script) just keeps changing for 1 or 2 seconds. When I restart then sending, the variables just begin to response a few seconds later (and so on...).
UDP shouldn't be the problem, because it's just sending an has no buffer itself (or am i wrong?). I tried different kinds of data transfer rates, nothing works. Furthermore the data is sent correct, I checked that with a Python script, there the delay doesn't appear. I tried different ports, too.
My question is, does FG have any kind of buffer itself? When yes, how can I send correct, so that the data arrives at the same time with the fdm data? When no, what might be the reason for this delay?
The problem is that I need this data to animate my model, so it's senseless if it doesn't "arrive" at the same time like the fdm data.
My command line to call FG:
fgfs --fdm=external --time-match-local --enable-random-objects --native-fdm=socket,in,60,,15710,udp --generic=socket,in,60,,15600,udp,peter_in --aircraft=...
Thanks for help!
Regards,
Peter