On Thu, 2009-10-29 at 13:57 +0100, Erik Hofman wrote:

Hi ya Erik,


      I just tried out the test3, no sound what so ever...

SimGear/source/simgear/sound> ./openal_test3
default position and orientation
NaN in source position
NaN in source orientation
playing sample
source at lat,lon = (10,-10), listener at (0.999,-0.999)
NaN in source position
NaN in source orientation
playing sample
SimGear/source/simgear/sound>

but test1 does work!!!
SimGear/source/simgear/sound> ./openal_test1
Buffer created ok!
AL lib: ALc.c:1640: exit(): closing 1 Device
AL lib: ALc.c:1569: alcCloseDevice(): destroying 1 Context
AL lib: ALc.c:1258: alcDestroyContext(): deleting 1 Source(s)
AL lib: ALc.c:1578: alcCloseDevice(): deleting 2 Buffer(s)
SimGear/source/simgear/sound>

test2 does not produce any sound :(
SimGear/source/simgear/sound> ./openal_test2
NaN in source position                                                                 
NaN in source orientation                                                              
playing sample1                                                                        
NaN in source position                                                                 
NaN in source orientation                                                              
NaN in source position                                                                 
NaN in source orientation
playing sample2
NaN in source position
NaN in source orientation
NaN in source position
NaN in source orientation
playing sample3
NaN in source position
NaN in source orientation
NaN in source position
NaN in source orientation
playing sample4
NaN in source position
NaN in source orientation
NaN in source position
NaN in source orientation
playing sample5
NaN in source position
NaN in source orientation
NaN in source position
NaN in source orientation
playing sample6
NaN in source position
NaN in source orientation


Hope that helps
   S.




Not really I updated the initialization of the sound sample position to 
prevent NaN's (by initializing it to SGGeod::fromDeg(0,0) but that 
places it far, far away from the sound manager that was still at (0,0) 
in OpenAL location.

I've updated that code in SimGear and added a third test program that 
tests (two) different lat/lon positions.

Erik

------------------------------------------------------------------------------
Come build with us! The BlackBerry(R) Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay 
ahead of the curve. Join us from November 9 - 12, 2009. Register now!
http://p.sf.net/sfu/devconference
_______________________________________________
Flightgear-devel mailing list
Flightgear-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/flightgear-devel