Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#63 $key

None
closed
None
5
2013-08-14
2005-06-07
Peter Ottis
No

I have installed the V 4.4.004. According the docs the
GTM should recognize the $KEY spec. variable, but my
system returns a null string. Am I missing something?

Peter

Discussion

  • Logged In: YES
    user_id=97924

    Peter, we apologize for the dealy in responding to your
    post. Could you please let us know the device for which you
    noticed $KEY not being maintained. Is it a FILE, or SOCKET,
    or some other? What is the sequence of M commands that
    reproduce this issue.

    Thanks,
    Vinaya

     
  • Peter Ottis
    Peter Ottis
    2005-06-19

    Logged In: YES
    user_id=964483

    I try to read the response (secape sequence) of function keys on
    a linux console in x-windows mode with following code:

    U $P:(NOECHO:ESCAPE) READ X#1 SET K=$KEY

    I am getting always K="" (i.e. $L(K)=0)

    I have no problems to get the values the "old way" using $ZB.
    Thanks
    Peter

     
  • Logged In: YES
    user_id=97924

    Peter, GT.M currently maintains $KEY (and $DEVICE) only for
    TCP, SOCKET and NIL devices. All other devices default to
    null string. As you have found out, the workaround is to use
    $ZB for TERMINAL devices. We apologize for any inconvenience
    this may cause. We will consider standardizing $KEY, $DEVICE
    behavior in GT.M in a future release.

    Thanks,
    Vinaya

     
  • Amul
    Amul
    2013-07-24

    • status: open --> closed
    • assigned_to: FIS GT.M Support
    • Group: -->
     
  • Amul
    Amul
    2013-07-24

    This will be fixed in the upcoming GT.M release. Version number TBD.

     
  • Amul
    Amul
    2013-07-24

    Status change to "Pending" since the release is pending.

     
  • Amul
    Amul
    2013-07-24

    • status: closed --> pending
     
  • Amul
    Amul
    2013-08-14

    • status: pending --> closed
     
  • Amul
    Amul
    2013-08-14

    Closed in V6.0-003