#331 Fire.fm player hasn't loaded (v. 1.4.12)

open
nobody
5
2011-01-26
2011-01-26
Anonymous
No

When I start firefox and try to play any station, I just get "Fire.fm player hasn't loaded" and no music.
fire.fm version: 1.4.12, firefox version: 3.6.13 (linux), flash version: 10.1.102.
I have NoScript and CS Lite installed as well.

Discussion

  • Please send us your log file so that we can look into this problem further:

    1) Locate your profile folder
    (http://support.mozilla.com/kb/Profiles#How_to_find_your_profile)
    2) Inside this folder, you should see a folder named "firefm". Open it.
    3) Inside this folder you'll see a file named "log.txt". Please send this
    file to us.

    Thanks

     
  • This is the content of the log file for the last two days:

    2011-01-26 13:14:43 FireFM.Station ERROR stop. Error trying to stop player:
    Error: Error calling method on NPObject!
    2011-01-26 13:14:43 FireFM.Station ERROR loadPlaylist. Error playing playlist.
    Error: TypeError: this._playerObj.getVolume is not a function
    2011-01-26 13:15:00 FireFM.Station ERROR stop. Error trying to stop player:
    Error: Error calling method on NPObject!
    2011-01-26 13:19:42 FireFM.PlayerInitializer FATAL _testPlayer. Flash player testing failed.
    2011-01-26 13:19:42 FireFMChrome.UIState ERROR _handlePlayerError. Status: 4
    2011-01-26 13:59:07 FireFM.PlayerInitializer FATAL _testPlayer. Flash player testing failed.
    2011-01-26 13:59:07 FireFMChrome.UIState ERROR _handlePlayerError. Status: 4
    2011-01-26 14:00:28 FireFM.PlayerInitializer FATAL _testPlayer. Flash player testing failed.
    2011-01-26 14:00:28 FireFMChrome.UIState ERROR _handlePlayerError. Status: 4
    2011-01-26 14:04:35 FireFM.PlayerInitializer FATAL _testPlayer. Flash player testing failed.
    2011-01-26 14:04:35 FireFMChrome.UIState ERROR _handlePlayerError. Status: 4
    2011-01-27 10:20:49 FireFM.PlayerInitializer FATAL _testPlayer. Flash player testing failed.
    2011-01-27 10:20:49 FireFMChrome.UIState ERROR _handlePlayerError. Status: 4

     
  • Can you play music normally is you go to http://www.last.fm/?
    Does this page (https://www.mozilla.com/en-US/plugincheck/) tell you that you have the latest version?

     
  • Yes, I can play music just fine with the flash player on last.fm's site.

    I have not quite the latest flash version but almost:
    I have flash-player-10.1.102.64 and the latest version from Adobe seems to be 10.1.102.65. However, the rpm from Adobe doesn't work for me - firefox doesn't seem to find the new flash lib or somesuch.
    However, as I said: the flash player on the last.fm site seems to work fine, so at least it is possible in theory to play music with that flash version ;-)

     
  • Can you please try disabling all your other extensions and then testing again? Does that make a difference?

    Thanks.

     
  • No difference at all, same message in the logs.
    Not even with all other plugins disabled AND the most recent flash version from Adobe (10.1.102.65).
    I have a 64bit system and use nspluginwrapper to use the 32bit flash plugin. That may make some difference - but the weird thing is that the flash player on the last.fm site plays music just fine...

     
  • BTW: update to fire.fm 1.4.13 hasn't changed anything.

     
  • It stop working for me a while ago too and I keep getting the message "The Fire.fm player hasn't loaded" a few seconds after I try to start a station in the bottom bar of the firefox browser window, just installed to latest update to be sure it's still the same problem (this is the tail from firefm/log.txt):

    2011-02-25 13:33:18 FireFM.PlayerInitializer FATAL _testPlayer. Flash player testing failed.
    2011-02-25 13:33:18 FireFMChrome.UIState ERROR _handlePlayerError. Status: 4

    Please advise

     
  • This error is caused by a communication problem between Fire.fm and the Flash player. It could be fixed by updating the Flash plugin:
    https://www.mozilla.com/en-US/plugincheck/
    However, there are some systems where we know the problem is persistent.

    Can you give us more information about your system: OS, Firefox version, Flash plugin version.

    Thanks.