#4409 grib-api-1.12.0 and grib-api-fortran-1.12.0

Added_to_Fink
closed-accepted
nobody
5
2014-05-16
2014-05-05
Remko Scharroo
No

This is an update for grib-api and grib-api-fortran to the latest release (1.12.0) by ECMWF.
This update also includes the switch to gcc49-compiler.
This makes my previous ticket regarding grib-api-fortran-1.9.18 moot.
Because the PDF manual that was included with the fink package grib-api-1.9.18 is no longer available on-line from ECMWF, I have removed it from the package.

Compiled and tested with "fink -m rebuild"
All tests passed.

Attached are
grib-api.info
grib-api.patch
grib-api-fortran.info

Attached are also the outputs of
dpkg -L grib-api > grib-api.lst
dpkg -L grib-api-bin > grib-api.lst
dpkg -L grib-api-shlibs > grib-api-shlibs.lst
dpkg -L grib-api-fortran > grib-api-fortran.lst
dpkg -L grib-api-fortran-shlibs > grib-api-fortran-shlibs.lst

8 Attachments

Discussion

    • labels: --> gcc49
     
    • labels: gcc49 --> gcc49, sci, Updated Version of Existing
    • Group: Undergoing_Validation --> Awaiting_Update_from_Submitter
     
  • When building grib-api-fortran:

    Can't resolve dependency "grib-api (= 1.12.0)" for package "grib-api-fortran-1.12.0-1" (no matching packages/versions found)

     
  • Remko Scharroo
    Remko Scharroo
    2014-05-10

    That's because you have not committed grib-api.info and grib-api.patch first. I've supplied the updated version of those too, above.

     
  • Nope. That's with the new grib-api.info/patch 1.12.0 from here already in my repository (just not committed to CVS yet). Switching the versioned BuildDepends to grib-api (= %v-1) makes Fink happy, but that would mean that grib-api and grib-api-fortran would need to be kept synced at the revision level, which would be a pain. Another (not very good) possibility would be add a BuildDepends: << 'some_higher_version_of_grib-api' to bound the allowable grib-api versions. However, this can cause deadlocks, as is happening with the several of the ocaml packages.

    How strict is the dependency of grib-api-fortran on grib-api? Must it match the version exactly, or only to the minor version fragment (1.12.0 vs 1.12) ?

     
  • Remko Scharroo
    Remko Scharroo
    2014-05-10

    Stange, I thought I had managed to do a "fink -m rebuild grib-api-fortran" with (= %v) in place.
    This BuildDepends did not use to be there, but I thought it would be wise to do so. I guess that "BuildDepends: grib-api (>= %v-1)" should be enough. Bit strange that Fink does not allow (= %v) that would sound like a natural thing to do.

     
    • status: open --> closed-accepted
    • Group: Awaiting_Update_from_Submitter --> Added_to_Fink
     
  • Added to the 10.7 tree with the >= change to the Depends field for grib-api