#4358 make-4.0-1

Supplanted
closed-out-of-date
Max Horn
None
5
2014-11-02
2013-10-25
Jack Howarth
No

The attached packaging updates make to the new 4.0 and makes the following changes…

1) the make.patch is dropped as it has no context in 4.0
2) --disable-nls is dropped as it works (at least all targets of 10.7 tree)
3) fink-package-precedence was added to BuildDepends to capture the expanded dependencies like gmp5 and guile18-dev as well as any potential lurking ones
4) 'perl -pi -e 's|-shared|-bundle -undefined dynamic_lookup|g' tests/scripts/features/load tests/scripts/features/loadapi' is used to properly link the load and loadapi test cases on darwin (thus eliminating 10 failures)

Tested on 10.7 with Xcode 4.6.3 and 10.8/10.9 with Xcode 5.0.1 using 'fink -m'. Note that there is a non-fatal failure…

misc/close_stdout ....................................... FAILED (no tests found!)

which simply reflects the fact that only linux has the /dev/full device used by this new test.

Discussion

  • Jack Howarth
    Jack Howarth
    2013-10-25

    Info file for make-4.0-1

     
    Attachments
  • Closing since make-4.1 was just checked into CVS.

     
    • status: open --> closed-out-of-date
    • Group: Undergoing_Validation --> Supplanted