Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#4222 flag-sort 0.5 -1to handle Xquartz in ML

open
Daniel Macks
5
2012-12-08
2012-12-08
Jack Howarth
No

The attached flag-sort 0.5-1 packaging adds the /opt/X11/lib and /opt/X11/include paths to the prefix order in flag-sort.patch to solve the r-base linkage issues. While updating the r-base215 package to BuildDepends on this version of flag-sort, the r-base215 package should be updated to the newest 2.15.2 release.Tested r-base215-2.15.2-1 with 'fink -m'.

Discussion

  • Jack Howarth
    Jack Howarth
    2012-12-08

    flag-sort 0.5-1 info file

     
    Attachments
  • Jack Howarth
    Jack Howarth
    2012-12-08

    flag-sort 0.5-1 patch file

     
    Attachments
  • Jack Howarth
    Jack Howarth
    2012-12-08

    r-base215-2.15.2-1 info file

     
    Attachments
  • Jack Howarth
    Jack Howarth
    2012-12-08

    r-base215-2.15.2-1 patch file

     
    Attachments
  • Jack Howarth
    Jack Howarth
    2012-12-08

    On 10.8 fink, the flag-sort 0.5-1/r-base215-2.15.2-1 packaging produces the linkage...

    % otool -L /sw/Library/Frameworks/R.framework/Versions/2.15/Resources/modules/R_X11.dylib
    /sw/Library/Frameworks/R.framework/Versions/2.15/Resources/modules/R_X11.dylib:
    /sw/Library/Frameworks/R.framework/Versions/2.15/Resources/modules/R_X11.dylib (compatibility version 0.0.0, current version 0.0.0)
    /opt/X11/lib/libSM.6.dylib (compatibility version 7.0.0, current version 7.1.0)
    /opt/X11/lib/libICE.6.dylib (compatibility version 10.0.0, current version 10.0.0)
    /sw/lib/pango-ft219/lib/libpangocairo-1.0.0.dylib (compatibility version 2401.0.0, current version 2401.5.0)
    /sw/lib/pango-ft219/lib/libpango-1.0.0.dylib (compatibility version 2401.0.0, current version 2401.5.0)
    /sw/lib/libgobject-2.0.0.dylib (compatibility version 2201.0.0, current version 2201.4.0)
    /sw/lib/libgmodule-2.0.0.dylib (compatibility version 2201.0.0, current version 2201.4.0)
    /sw/lib/libglib-2.0.0.dylib (compatibility version 2201.0.0, current version 2201.4.0)
    /sw/lib/libintl.8.dylib (compatibility version 10.0.0, current version 10.1.0)
    /usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.5)
    /sw/lib/libcairo.2.dylib (compatibility version 10803.0.0, current version 10803.10.0)
    /opt/X11/lib/libX11.6.dylib (compatibility version 10.0.0, current version 10.0.0)
    /opt/X11/lib/libXt.6.dylib (compatibility version 7.0.0, current version 7.0.0)
    /opt/X11/lib/libXmu.6.dylib (compatibility version 9.0.0, current version 9.0.0)
    /sw/lib/libtiff.3.dylib (compatibility version 13.0.0, current version 13.4.0)
    /sw/lib/libjpeg.8.dylib (compatibility version 13.0.0, current version 13.0.0)
    /sw/lib/libpng15.15.dylib (compatibility version 26.0.0, current version 26.0.0)
    /sw/Library/Frameworks/R.framework/Versions/2.15/Resources/lib/libR.dylib (compatibility version 2.15.0, current version 2.15.2)
    /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 744.12.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 169.3.0)

     
  • Jack Howarth
    Jack Howarth
    2012-12-08

    The r-base215.patch is the same as in current fink. The r-base213 and r-base214 info files need the flag-sort (>= 0.5) change in their BuildDepends.