Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#3224 update to FTGL patch

Added_to_Fink
closed-works-for-me
nobody
5
2009-01-10
2008-04-12
No

This is a small fix to get this working on Xcode 3.0 on 10.5. I had previously tested on Xcode 3.1 and 2.5 only

Discussion

    • milestone: 373615 --> 373614
     
  • Logged In: YES
    user_id=353035
    Originator: NO

    It didn't work for me on 10.5 with Xcode 3.0:
    ...
    /bin/sh ../libtool --mode=link g++ FTGLDemo.o tb.o trackball.o -o FTGLDemo ../src/libftgl.la -L/usr/X11/lib -lfreetype -lz -Wl,-framework,CoreServices,-framework,ApplicationServices -Wl,-framework,GLUT -Wl,-framework,OpenGL -lobjc
    g++ FTGLDemo.o tb.o trackball.o -o .libs/FTGLDemo -Wl,-framework -Wl,CoreServices -Wl,-framework -Wl,ApplicationServices -Wl,-framework -Wl,GLUT -Wl,-framework -Wl,OpenGL -L../src/.libs -lftgl -L/sw2/lib -L/usr/X11/lib -lfreetype -lz -lobjc
    ld: cycle in dylib re-exports with /usr/X11/lib/libGL.dylib
    collect2: ld returned 1 exit status
    make[1]: *** [FTGLDemo] Error 1

    Does it need the workaround from http://wiki.finkproject.org/index.php/Fink:Packaging:Preparing_for_10.5#OpenGL_Bug
    ?

     
  • Logged In: YES
    user_id=60552
    Originator: NO

    See also tracker item #1919196 which I have reopened.

     
  • The current version in CVS builds for me on Mac OS X 10.5.6 using Xcode 3.1.2 (gcc build 5490). It seems to only be an issue on Xcode 3.0. I don't have access to a machine running Xcode 3.0. Is there any use in supporting Xcode 3.0?

     
    • milestone: 373614 --> 373615
     
    • milestone: 373615 --> Added_to_Fink
    • status: open --> closed-works-for-me
     
  • Updated in Fink. We do have the option of a versioned Dependency on xcode >=3.1.1 if we'd like.