#2070 New package: loudmouth

Added_to_Fink
closed-works-for-me
nobody
5
2007-02-08
2005-10-15
Michael Wybrow
No

Loudmouth is a lightweight and easy-to-use C library
for programming with the Jabber protocol.

Website: http://developer.imendio.com/wiki/Loudmouth

Tree: 10.3 (untested), 10.4 (tested, works great!)
Section: libs
Validated: yes

Discussion

1 2 3 > >> (Page 1 of 3)
  • Daniel Macks
    Daniel Macks
    2005-10-17

    Logged In: YES
    user_id=535292

    During ./configure, I get:

    checking for pkg-config... /sw/bin/pkg-config

    which means you need BuildDepends: pkgconfig in your .info.
    And then:

    checking for GLIB - version >= 2.0.0... no
    *** Could not run GLIB test program, checking why...
    *** The test program failed to compile or link. See the file
    config.log for the
    *** exact error that occured. This usually means GLIB is
    incorrectly installed.
    checking what warning flags to pass to the C compiler...
    checking for tm_gmtoff in struct tm... yes
    checking for glib-2.0 >= 2.4.0... Package glib-2.0 was not
    found in the pkg-config search path. Perhaps you should add
    the directory containing `glib-2.0.pc' to the
    PKG_CONFIG_PATH environment variable No package 'glib-2.0' found
    configure: error: Library requirements (glib-2.0 >= 2.4.0)
    not met; consider adjusting the PKG_CONFIG_PATH environment
    variable if your libraries are in a nonstandard prefix so
    pkg-config can find them.

    I see there's a Depends: glib2-shlibs in the .info, but it
    appears you're missing a BuildDepends for whatever package
    supplies that .pc file. The general approach you should take
    is: for everything your package uses, you need BuildDepends
    on its headers package and your -shlibs needs Depends on its
    -shlibs (and other runtime packages). By "uses", you should
    look at the output of ./configure and also run 'otool -L' on
    the compiled binaries.

    Also, your Depends (and whatever BuildDepends) should
    contain the fink equivalent of the versioning requirement
    mentioned in the above error message, for example: Depends
    glib2-shlibs (>= 2.4.0-1)

    I see there's a CONTRIBUTORS file in the tarball. Might be
    polite to include it in the DocFiles lines.

     
  • Daniel Macks
    Daniel Macks
    2005-10-17

    • milestone: 373615 --> 373614
     
  • Michael Wybrow
    Michael Wybrow
    2005-10-19

    Logged In: YES
    user_id=1110550

    Thanks for you comments Daniel, I have fixed these issues in
    the attached updated info file.

     
  • Michael Wybrow
    Michael Wybrow
    2005-10-19

    • milestone: 373614 --> 373615
     
  • Logged In: YES
    user_id=842097

    I have a package for loudmouth and gossip in my experimental branch (exp/
    bmaret). Feel free to use them if you need.

     
  • Michael Wybrow
    Michael Wybrow
    2006-05-02

    Info file for loudmouth-1.0.3

     
    Attachments
  • Michael Wybrow
    Michael Wybrow
    2006-05-02

    Logged In: YES
    user_id=1110550

    Since this still hasn't been added, and there have been a
    couple of bugfix releases of loudmouth in the meantime, I
    have trivially updated the attached info file to be for
    loudmouth 1.0.3, the current stable version.

     
    • milestone: 373615 --> 373614
     
  • Logged In: YES
    user_id=286406

    Thanks for this package submission and sorry that nobody
    looked at it in such a long time. There are, however, a
    couple of problems with this info file:

    1)
    You should use the newer gettext library, e.g.
    libgettext3-shlibs and libgettext3-dev

    2)
    Validating .deb dir root-loudmouth-1.0.5-1...
    Error: Headers installed in /sw/include, as well as a dylib,
    but package does not declare BuildDependsOnly to be true (or
    false)

    3)
    According to
    http://fink.sourceforge.net/doc/packaging/policy.php#
    sharedlibs
    libloudmouth-1.dylib goes into -dev, and
    libloudmouth-1.0.dylib and libloudmouth-1.0.0.0.dylib go
    into -shlibs

    4)
    There is a new upstream version, 1.0.5.

    I fixed all these problems (see attached .info) and the
    pacakge builds fine now. However, I didn't really test it.

    Could you comment on these changes and test the new .info
    file? If you are ok with it I will commit it.

     
  • loudmouth 1.0.5, with fixes by chris01

     
    Attachments
1 2 3 > >> (Page 1 of 3)