#1635 Uninitialized value $growl_version

10.8
open
nobody
growl (1)
5
2013-09-18
2013-09-18
Michael Schmitt
No

When Fink scans packages, VirtPackage.pm doesn't recognize Growl version strings of the form 1.2.2f1, as used by the Growl Fork.

The error is:

Use of uninitialized value $growl_version in string eq at /sw/lib/perl5/Fink/VirtPackage.pm line 1721.

If I run fink-virtual-pkgs --debug, it says:

    :
  - system-xfree86 provides xfree86-base-threaded
- checking for Growl... found, Growl
- checking for Growl version... Use of uninitialized value $growl_version in string eq at /sw/lib/perl5/Fink/VirtPackage.pm line 1721.
unknown
Package: 64bit-cpu
     :

Discussion

  • Oops: fink version is:
    Package manager version: 0.35.1
    Distribution version: selfupdate-cvs Tue Sep 17 01:22:20 2013, 10.8, x86_64
    Trees: local/main stable/main unstable/crypto unstable/main