#1616 gnome-keyring should depend on gconf2

10.5_(32-bit_Intel)
closed-accepted
nobody
5
2011-05-24
2010-07-19
GodFarmer
No

Hello,

About a month ago, I send the following report to the maintainer of gnome-keyring. There was no response. It seems an obvious problem though.

Best,
Bruno De Fraine

Report:

Hello Dave,

I was monitoring how one of my packages is built on fink.sodan.ecc.u-tokyo.ac.jp and I noticed that it fails because of an installation problem with gnome-keyring. The problem is the following:

/sw/var/lib/dpkg/info/gnome-keyring.postinst: line 8: gconftool-2: command not found
/sw/var/lib/dpkg/info/gnome-keyring.postinst: line 9: gconftool-2: command not found
/sw/bin/dpkg: error processing gnome-keyring (--install):
subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
gnome-keyring

It seems this package simply has to depend on "gconf2" instead of "gconf2-shlibs", because the former is what provides gconftool-2. So I wanted to report this as a bug.

If you want to see the full installation log, you can check it here:
http://fink.sodan.ecc.u-tokyo.ac.jp/build-10.5-i386/2010-06-21/coqide.err.gz

Best regards,
Bruno De Fraine

Discussion

  • Fixed now.

     
    • status: open --> closed-accepted