#1227 findbugs on Maven central

2.0.3
closed-fixed
William Pugh
None
5
2014-06-19
2013-11-25
hgschmie
No

Has not shown up on maven central yet, which severely hampers my ability to use findbugs in our maven projects. Any ETA for that?

Related

Bugs: #1227

Discussion

  • William Pugh
    William Pugh
    2013-12-12

    Thanks for your help.

    I'm getting the following error:
    [dhcp322:~/Documents/findbugs-git] pugh% mvn release:prepare
    [INFO] Scanning for projects...
    [ERROR] The build could not read 1 project -> [Help 1]
    [ERROR]
    [ERROR] The project com.google.code.findbugs:findbugs-project:2.0.3-SNAPSHOT (/Users/pugh/Documents/findbugs-git/pom.xml) has 1 error
    [ERROR] Child module /Users/pugh/Documents/findbugs-git/findbugs-package of /Users/pugh/Documents/findbugs-git/pom.xml does not exist
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException

     
  • William Pugh
    William Pugh
    2013-12-12

    OK, I fixed this problem by doing it from within the findbugs subdirectory.

    Now I'm having a problem with building the javadoc via maven.

    I get this both when I run mvn release:prepare or mvn javadoc:javadoc

    I've pushed release-2.0.3 to the repository if you want to try to examine the problem I'm getting.

     
  • Kengo TODA
    Kengo TODA
    2013-12-13

    Oh, it looks pom.xml is invalid at this commit. Sorry I didn't check it.
    And I found a test failure in my PC. I think maven-release-plugin is not good way to deploy.

        java.lang.IllegalStateException: Invalid method signature: '(!*)V' : !*)V 
            at edu.umd.cs.findbugs.ba.generic.GenericSignatureParser$ParameterSignatureIterator.next(GenericSignatureParser.java:115)
            at edu.umd.cs.findbugs.ba.generic.GenericSignatureParser$ParameterSignatureIterator.next(GenericSignatureParser.java:45)
            at edu.umd.cs.findbugs.ba.generic.GenericUtilities.getTypeParameters(GenericUtilities.java:401)
    

    So it is better to try to deploy existed artifacts by maven-gpg-plugin including pom, jar, sources-jar and javadoc-jar.

    At least Garvin LeClaire can deploy them, because he has permission to deploy.
    You and I are also possible but we need to get permission from Sonatype. I will try to get.

     
  • William Pugh
    William Pugh
    2013-12-13

    Can you give me the corrected pom.xml file?

     
  • hgschmie
    hgschmie
    2013-12-13

    Hi William,

    as you release your software outside the maven cycle, release:prepare and release:perform require additional steps to work. Easiest would be to use direct artifact deployment using the maven deploy plugin, because you already have generated the artifacts.

    A few notes:

     
  • Kengo TODA
    Kengo TODA
    2013-12-14

    Hi William,

    Can you give me the corrected pom.xml file?

    I think pom.xml in master is OK because we fixed at #1229 and other commits, We can try release plugin from next release.

    BTW, I got permission to deploy onto SonaType repo. Can I deploy 2.0.3?
    Or you can try by yourself, I think hgschmie's guide is quite good and kind.

     
    • William Pugh
      William Pugh
      2013-12-14

      Yes, you can go ahead and deploy 2.0.3. I think I've getting the hang of it, but I think you have more experience with it and it is more likely to go correctly if you do it.

      Bill

      On Dec 14, 2013, at 1:58 AM, eller86 eller86@users.sf.net wrote:

      Hi William,

      Can you give me the corrected pom.xml file?

      I think pom.xml in master is OK because we fixed at #1229 and other commits, We can try release plugin from next release.

      BTW, I got permission to deploy onto SonaType repo. Can I deploy 2.0.3?
      Or you can try by yourself, I think hgschmie's guide is quite good and kind.

      [bugs:#1227] findbugs on Maven central

      Status: open
      Created: Mon Nov 25, 2013 06:25 PM UTC by hgschmie
      Last Updated: Fri Dec 13, 2013 05:48 PM UTC
      Owner: nobody

      Has not shown up on maven central yet, which severely hampers my ability to use findbugs in our maven projects. Any ETA for that?

      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/findbugs/bugs/1227/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       

      Related

      Bugs: #1227

      Attachments
      • Kengo TODA
        Kengo TODA
        2013-12-15

        I got, I will do it.

        Do I need to deploy other artifacts under com.google.code.findbugs groupId? I mean that do bcel, jsr305, findbugs-ant, annotations and jformatString have version 2.0.3?
        In pom.xml, findbugs depends on 2.0.1 of bcel, jsr305 and jformatString. So I guess that only findbugs-ant and annotations has version 2.0.3.

         
  • William Pugh
    William Pugh
    2013-12-16

    I think we've managed to get 2.0.3 successfully deployed to maven. Thanks eller86. Do people concur that this item can be closed?

     
  • William Pugh
    William Pugh
    2013-12-16

    • status: open --> closed-fixed
    • assigned_to: William Pugh
     
  • hgschmie
    hgschmie
    2013-12-16

    If JSR 305 and bcel are unchanged, can we deploy the same versions as 2.0.3? The problem is that a lot of code uses a ${dep.findbugs.version} property in their poms to refer to the various pieces of findbugs and now updating that version to 2.0.3 will break because e.g. jsr305 does not exist in that version.

     
    • William Pugh
      William Pugh
      2013-12-16

      jsr305 and bcel are unchanged.

      I've reopened the ticket.

      Bill

      On Dec 16, 2013, at 12:56 PM, hgschmie hgschmie@users.sf.net wrote:

      If JSR 305 and bcel are unchanged, can we deploy the same versions as 2.0.3? The problem is that a lot of code uses a ${dep.findbugs.version} property in their poms to refer to the various pieces of findbugs and now updating that version to 2.0.3 will break because e.g. jsr305 does not exist in that version.

      [bugs:#1227] findbugs on Maven central

      Status: closed-fixed
      Created: Mon Nov 25, 2013 06:25 PM UTC by hgschmie
      Last Updated: Mon Dec 16, 2013 04:32 PM UTC
      Owner: William Pugh

      Has not shown up on maven central yet, which severely hampers my ability to use findbugs in our maven projects. Any ETA for that?

      Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/findbugs/bugs/1227/

      To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

       
      Attachments
  • hgschmie
    hgschmie
    2013-12-16

    How do I reopen this ticket? I do not think that it is fixed yet.

     
  • William Pugh
    William Pugh
    2013-12-16

    • status: closed-fixed --> open-accepted
     
  • Kengo TODA
    Kengo TODA
    2013-12-19

    findbugs:2.0.3 is now on central, but others are not yet. I will restart this task next week.

     
  • Kengo TODA
    Kengo TODA
    2013-12-24

    Hello ALL,
    could you tell me where is source code of each library? They are necessary to deploy libraries to Maven Central via Sonatype repository. Current my understanding is below:

    • findbugs-ant: findbugs/src/antTask directory in the same repository
    • annotations: findbugs/src/java/edu/umd/cs/findbugs/annotations directory in the same repository
    • jsr305: in another google code repository
    • jFormatString: unknown
    • bcel: unknown

    Thanks in advance,
    Kengo

     
    • status: open-accepted --> closed-fixed